Logitech X-230 subwoofer won't turn on (TDA7377) - diyAudio
Go Back   Home > Forums > Amplifiers > Chip Amps

Chip Amps Amplifiers based on integrated circuits

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 6th March 2011, 10:07 AM   #1
diyAudio Member
 
Join Date: Mar 2011
Unhappy Logitech X-230 subwoofer won't turn on (TDA7377)

Hello guys,
I need help with turning on the subwoofer from this speakers set. Whole amp is based on TDA7377, while two satellites uses two channels and subwoofer uses another two in bridge.

There is something like control pod in the left satellite, but it is basically only volume control, led, switch and headphone connector. Then the connection goes to the subwoofer through DE-9 (RS 232) 9 pin connector. I got the whole set with that connector cut off.

I have googled for some pinouts and wired a new connector. The two satellites work without problem, also switching circuit works. But there is no sound coming from subwoofer. The driver is good, I have tested it. There is no sound signal in wires going to subwoofer, only that silent noise with 50 Hz in background, like amp turned to max without any input signal.

I can supply pinouts and more info.
  Reply With Quote
Old 8th March 2011, 09:48 AM   #2
diyAudio Member
 
Join Date: Apr 2010
* check is there signal on preamp circut for sub (4558 op amp. or similar).
* check voltage on on sub amp. (is it corect 12 - 15v aprox.)
* dont bother wit pin layout on conector it is diferent from each speakers model.
sorry for my bad engl.
  Reply With Quote
Old 8th March 2011, 10:29 AM   #3
diyAudio Member
 
Join Date: Apr 2010
TDA 7377 has a diagnostic circut for shotcircut,cliping,overheating etc.(protection)
You must check pcb is it OK.No shortcircut on it.
If is something wrong the TDA7377 will go in standby mode,no sound on sub speaker.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
TDA7377 Opinions Please TechnoBeaver Chip Amps 2 6th April 2010 02:47 AM
Help needed troubleshootiung Logitech Z560 subwoofer amp DcibeL Solid State 15 25th November 2004 06:35 AM
Subwoofer pops when I turn on/off from deck feelinhipp Car Audio 10 19th July 2004 09:35 PM
info on TDA7377 Stefano Parts 3 11th June 2003 06:58 AM


New To Site? Need Help?

All times are GMT. The time now is 08:26 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2