diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Chip Amps (http://www.diyaudio.com/forums/chip-amps/)
-   -   Logitech X-230 subwoofer won't turn on (TDA7377) (http://www.diyaudio.com/forums/chip-amps/184522-logitech-x-230-subwoofer-wont-turn-tda7377.html)

lantian 6th March 2011 11:07 AM

Logitech X-230 subwoofer won't turn on (TDA7377)
 
Hello guys,
I need help with turning on the subwoofer from this speakers set. Whole amp is based on TDA7377, while two satellites uses two channels and subwoofer uses another two in bridge.

There is something like control pod in the left satellite, but it is basically only volume control, led, switch and headphone connector. Then the connection goes to the subwoofer through DE-9 (RS 232) 9 pin connector. I got the whole set with that connector cut off.

I have googled for some pinouts and wired a new connector. The two satellites work without problem, also switching circuit works. But there is no sound coming from subwoofer. The driver is good, I have tested it. There is no sound signal in wires going to subwoofer, only that silent noise with 50 Hz in background, like amp turned to max without any input signal.

I can supply pinouts and more info.

Dragance 8th March 2011 10:48 AM

* check is there signal on preamp circut for sub (4558 op amp. or similar).
* check voltage on on sub amp. (is it corect 12 - 15v aprox.)
* dont bother wit pin layout on conector it is diferent from each speakers model.
sorry for my bad engl.

Dragance 8th March 2011 11:29 AM

TDA 7377 has a diagnostic circut for shotcircut,cliping,overheating etc.(protection)
You must check pcb is it OK.No shortcircut on it.
If is something wrong the TDA7377 will go in standby mode,no sound on sub speaker.


All times are GMT. The time now is 09:36 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2