diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Chip Amps (http://www.diyaudio.com/forums/chip-amps/)
-   -   Finalizing TDA2050, LM3886 (http://www.diyaudio.com/forums/chip-amps/152471-finalizing-tda2050-lm3886.html)

pra3718 25th September 2009 10:21 AM

Finalizing TDA2050, LM3886
 
1 Attachment(s)
I build TDA2050 as per ESP. 5 Nos Amp on single heat sink size 4" x 12" All 5 amps are sounding good individually. As I read proper grounding is required for gainclone so I wish to verify.

Ground Point 1: Connects Input 22K+220pf AND 47uf 25V AND RC ground.
Ground Point 2: Connects Power Ground AND 1R 1/2 Watts AND Speaker Ground.

Above 1 & 2 ground points are connect with single wire.

NOW, I wish to connect those all 5 Nos amps to single PSU (transformer) which is the best way ? ( I HAVE ALREADY DAMAGED 4 NOS CHIPS AND ONE TRANSFORMER, I DON'T WANT TO TAKE A RISK THIS TIME !)

Option I : As attached picture, with this option I found lot-off wire in the system.

Or better option !

pacificblue 25th September 2009 12:45 PM

Your drawing shows the best option.

Build yourself a dim bulb tester or light bulb tester as it is also called and use it each time you power your amplifier up until you know that everything works correctly. A building example can be found here.

pra3718 26th September 2009 10:05 AM

Single Transformer supply to 2050 & 3886
 
1 Attachment(s)
Thank you Pacificblue

Bigger transformer is expensive. Can I use single transfomer PSU for TDA2050 & LM3886 ? I don't have multimeter to check is it possible as per attached picture ?

pacificblue 27th September 2009 07:05 PM

You can use the transformer for the LM3886, but not for the TDA2052.
You get ~33 V per rail, so the LM3886 will probably run hot with 4 Ohm speakers.
The 10 F capacitors need a higher voltage rating.

AndrewT 27th September 2009 07:26 PM

re post3.
You cannot get both 35V and 25V from the same PSU.
The lower LED is back to front.
What are all the extras for?
You need a transformer, a rectifier and a pair of smoothing capacitors.
The worst case voltage from your 24Vac transformer will be about 38Vdc (if regulation ~7%). You must not use a 25V capacitor across this.

Do any of the amplifiers drive a full range speaker or a bass speaker?
Then the +-4700uF is far too small for all those amplifiers.

The 4k7 resistors will dissipate just over 240mW. use 500mW or 600mW and stand them off the PCB, they will run warm.

pra3718 28th September 2009 07:32 AM

1 Attachment(s)
Quote:

"You cannot get both 35V and 25V from the same PSU."
Then If I want I will have to use two transformer. But PB advised not to run 4ohm speaker cause IC run HOT. So, 18-0-18 would be good to run 5 Nos TDA2050 & 1 Nos LM3886.

Quote:

"Then the +-4700uF is far too small for all those amplifiers."
if I use 18-0-18 transformer i.e. 25v +- . I should increase caps on PSU. Is 10000uf good to run those 6 amps.

Reply Post # 2, Pacificblue as you advised, I build bulb tester as I understood ( I am not electronics man so I cannot understand electronics language properly) Please find attached picture.

Before trying/powering all amps individualy I test all amps by ( speaker polarity tester ) touch (-) polarity to heatsink and (+) polarity to all points on PCB. Like (+), (-) and ground. If the speaker does not jump i.e. it is not short to heatsink. Even I test this-way for my damage chip it was jumping.

2nd test with ( speaker polarity tester ) If I touch (-) polarity to back-side of the IC, speaker jump only when I touch the IC's PIN no.3. And very little on PIN no.5.

After above test, I attached bulb tester & powerd only one amp. I found, bulb is not glowing and amp is sounding good. ( I could not understand why bulb is not glowing )

As per Post # 1 picture I wired all amp and powerd (Bulb tester is still attached) Bulb glow very little. WHEN I ATTACH DVD PLAYER ALL 6 CHANNEL OUTPUT TO ALL TDA2050 RC SOCKET. BULB GLOW VERY BRIGHT ( Is this normal ? )

BUT AFTER 5 MIN. I FOUND TRANSFORMER BECOME VERY HOT AGAIN.

I am confused why this happening. My one 18-0-18 transformer meltdown, I did not purchased new one. And this all I am trying with 12-0-12 5 amp transformer. Is that reason ?

ONE THING PACIFICBLUE, TDA2050 SOUNDS POWERFULL THEN TDA1554Q ACCEPT SWEET HIGH-FREQUENCY. BUT THIS CAN BE TUNED AFTER ALL AMPS STABLE.

Thank you & Regards.

AndrewT 28th September 2009 09:53 AM

Quote:

Originally Posted by pra3718 (Post 1935745)
After above test, I attached bulb tester & powerd only one amp. I found, bulb is not glowing and amp is sounding good. ( I could not understand why bulb is not glowing )

the bulb = off, tells you the connected circuit is drawing very low current. That is good.
Quote:

Originally Posted by pra3718 (Post 1935745)
As per Post # 1 picture I wired all amp and powerd (Bulb tester is still attached) Bulb glow very little. WHEN I ATTACH DVD PLAYER ALL 6 CHANNEL OUTPUT TO ALL TDA2050 RC SOCKET. BULB GLOW VERY BRIGHT ( Is this normal ? )
BUT AFTER 5 MIN. I FOUND TRANSFORMER BECOME VERY HOT AGAIN.

The bulb glowing or bright tells you high current is passing. That is bad. There is a serious fault, if it is bright. Switch off and test for the fault.
If the transformer is HOT, then the fault is probably in the transformer wiring.
Disconnect all the amplifiers and bulb test the transformer and PSU.

pacificblue 28th September 2009 02:18 PM

You should be careful with that battery you use for testing. 1,5 V DC at the amplifier input can lead to high DC voltage at the speaker output.

Six amplifiers on a 120 VA transformer could be asking too much of the transformer.

If the amplifier is reproducing music on all channels, the light bulb must become bright, because more current flows. It is important that the bulb stays off or remains dim, when the amplifier is powered, but no music is playing. In that condition you can make all necessary measurements to make sure there is no fault. Once you are sure that everything is working correctly, you can remove the bulb tester and check everything with music.

pra3718 30th September 2009 10:42 AM

Thank you, I understood BULB TESTER stuff. But problem is not solved. If I test amp one-by-one all sounds good but not when integrated. Can you post any schematic or link for 6 channel wiring i.e. (+), (-), RC ground, Power ground.

pacificblue 30th September 2009 02:11 PM

What changes do you perceive in the sound? Is the amplifier clipping, because the transformer is and/or smoothing capacitors are too small? Then the wiring will not make a difference.


All times are GMT. The time now is 05:25 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2