Help with tda7375 - diyAudio
Go Back   Home > Forums > Amplifiers > Chip Amps

Chip Amps Amplifiers based on integrated circuits

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 28th April 2008, 05:23 PM   #1
Nenola is offline Nenola  Finland
diyAudio Member
 
Join Date: Feb 2008
Default Help with tda7375

I tried to seach this forum for some improvements for the National's datasheet schematic for tda7375.

I tried the stereo/bridge schematic, but it gives me constant hum in "out L" and "out bridge". The "out R" is quite silent. I'm not using a custom pcb, the components are practically soldered to the pins straight. The vcc pin and the other input pin are next to each other, so can this cause the hum? Could I add somekind of additional filter to the input?

I know that a good pcb would be wise to use, but I don't have the possibility to make one.

Oh, and my psu is 12 volt trafo separate from the amp, so that can't cause the hum, or can it?
Attached Images
File Type: jpg nimetön.jpg (30.0 KB, 319 views)
  Reply With Quote
Old 29th May 2008, 10:27 AM   #2
Nenola is offline Nenola  Finland
diyAudio Member
 
Join Date: Feb 2008
Hi all!

I did some more reading and realized that the hum came from the psu, because my trafo gave 12 VAC out so I had added a bridge rectifier to it. Now I added two caps to the PSU and the amp runs nice and silent.

I'm trying to put the whole mess into a case so maybe you'll see it in the chipamp pics later.
  Reply With Quote
Old 26th August 2008, 06:56 AM   #3
Nenola is offline Nenola  Finland
diyAudio Member
 
Join Date: Feb 2008
Hello!

I've had this amp in use for a while, but I noticed that I still get some hum in other channel.
My amp is now in an ATX-psu case with the trafo, so it probably isn't the best option, but I still think that this amp could hum less. I'm going to make a proper PCB soon, but what other things could I do to reduce the hum?
Now I have one 4700uF and one 2200uF cap after the rectifier. What kind of caps do you suggest I could use in the rectifier itself, and will it reduce the hum?
  Reply With Quote
Old 26th August 2008, 08:58 AM   #4
eketehe is offline eketehe  Indonesia
diyAudio Member
 
eketehe's Avatar
 
Join Date: Nov 2007
Hv a 7812 or better regulator+ more 220uF before chips
  Reply With Quote
Old 26th August 2008, 11:38 AM   #5
galeb is offline galeb  Spain
diyAudio Member
 
Join Date: Apr 2008
Default hum with tda7375 amp

Hi,

I do not know if you wired correctly the ground, if not, you have to get 1 wire ground of each board and connect it at 1 point at the chassi of the amp. You have to insulate the RCAs from the chassi.

Hope this helps
__________________
galeb saleh
Sarte Audio Elite´s technical audio department
  Reply With Quote
Old 26th August 2008, 01:30 PM   #6
Nenola is offline Nenola  Finland
diyAudio Member
 
Join Date: Feb 2008
Where should I add the 220uF cap? As you can see, I have 1000uF and 100nF caps on the board and 4700uF and 2200uF in the voltage rail.
I'll also need to check the grounding, thanks!
Can a ground-problem create hum in one channel only? Because the other channel is totally hum-free.
  Reply With Quote
Old 7th October 2008, 03:15 PM   #7
Nenola is offline Nenola  Finland
diyAudio Member
 
Join Date: Feb 2008
Hi all!

I've had this amp up and running for a while. I'm still having the hum-problem and no decent PCB. I also haven't got a decent low-pass filter done for the bridge channel, so I'm planning on modifying the amplifier to stereo.

I made a quick sketch about the PCB I was going to make. I also added the regulator to the board. It's there to limit the standby-pin voltage.

I didn't remember to display the component values, but I have 470n as input caps and 1000u and 100n in the supply rail.

So how does the PCB look like?

Click the image to open in full size.
  Reply With Quote
Old 3rd March 2009, 02:15 PM   #8
diyAudio Member
 
Join Date: Feb 2009
Quote:
Originally posted by eketehe
Hv a 7812 or better regulator+ more 220uF before chips
Not with an amp chip that can quite easily draw more then 1 amp that a standard 3 pin regulator is limited to.

As for the hum, have you earthed BOTH pins on the chip? There is a SG earth and a PW earth, they should both be earthed together.

Go over your circuit and make sure it matches the one shown in the data sheet.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I need help on TDA7375 ahonda55 Solid State 6 2nd July 2007 08:34 PM
TDA7375 as a subwoofer amp JAZZ2250 Chip Amps 5 18th May 2005 05:31 PM


New To Site? Need Help?

All times are GMT. The time now is 05:45 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2