Pioneer A-P510 amplifier schematics or service manual - diyAudio
Go Back   Home > Forums > Amplifiers > Chip Amps

Chip Amps Amplifiers based on integrated circuits

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th November 2007, 02:41 PM   #1
diyAudio Member
 
Join Date: Mar 2006
Location: Great Yarmouth, UK
Default Pioneer A-P510 amplifier schematics or service manual

I've been given this amplifier to look at. It is part of a 'mini system', or I think that's what they're called. It is a complete system with an amplifier & preamp, tape deck, tuner, "sound processor" and CD player. In order to get the amp to switch on, you MUST have at least the "sound processor" and tuner connected it seems. They're connected at the back via ribbon cables.

It came to me and I was told it would no longer turn on at all. I didn't bother checking, but looked inside the amplifier unit and saw that the PCB was caked in dust. You couldn't actually see the PCB silkscreen anymore... anywhere! So I dismantled it and cleaned off all the dust with a small paint brush. I then proceeded to try turning it on, and it seems to be turning on alright. Whether it was before is a complete mystery, but I doubt the cleaning did any harm

Whilst cleaning I found out that it uses an STK4172 chip for the amplifier. The chip is HUGE!

I tested it with the DMM and there appears to be < 1mV DC on the outputs, but when I switch to AC it reads about 0.3v. Seems a bit odd to me. I checked the output with the scope and no load, and there is what looks to be about a 1v wave, which looks to be *maybe* 60Hz or so... but get this.... this appears on the output even when the unit is in standby! I guess maybe the standby on it doesn't really switch a lot of stuff off or something.

I have connected a small test speaker however.... and I don't appear to be getting any output from it at all, which I find odd. The wave I previously mentioned isn't to be heard, and selecting the tuner as the source... I still hear nothing.

So I am just wondering if anyone happens to have a schematic or service manual for this amplifier, or even any suggestions where to start looking (I fear this is going to be very difficult without a schematic though).

Thanks in advance,
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
pioneer amplifier service manual clipto333 Car Audio 3 16th December 2007 12:09 PM
Need Pioneer RT-909 Service Manual P909 Analogue Source 3 6th March 2007 07:34 AM
Service Manual Pioneer C73 Macrom Solid State 3 14th February 2006 01:02 PM
Need Service Manual For Pioneer PD-S 904 CDP rameish Digital Source 0 22nd June 2004 05:32 AM
Service Manual Pioneer PDS-904 hifi Everything Else 1 24th October 2002 02:51 PM


New To Site? Need Help?

All times are GMT. The time now is 03:29 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2