ARGH! One channel failed ... where to start? - diyAudio
Go Back   Home > Forums > Amplifiers > Chip Amps

Chip Amps Amplifiers based on integrated circuits

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 23rd July 2007, 12:43 PM   #1
diyAudio Member
 
paulspencer's Avatar
 
Join Date: Sep 2003
Location: Melbourne, Australia
Default ARGH! One channel failed ... where to start?

It's an ESP chip amp and one channel has failed. It happened when I stood on some cables, I heard a little zap, the sound cut out from one channel. I've checked cables and they all seem fine. I also can't see how I could have caused any fault.

Now I'm a little stuck. I know how to identify the parts and follow plans, but not how to fix.

Can anyone suggest where to start, what to look for?
  Reply With Quote
Old 23rd July 2007, 12:44 PM   #2
diyAudio Member
 
jan.didden's Avatar
 
Join Date: May 2002
Location: Great City of Turnhout, Belgium
Blog Entries: 7
Default Re: ARGH! One channel failed ... where to start?

Quote:
Originally posted by paulspencer
It's an ESP chip amp and one channel has failed. It happened when I stood on some cables, I heard a little zap, the sound cut out from one channel. I've checked cables and they all seem fine. I also can't see how I could have caused any fault.

Now I'm a little stuck. I know how to identify the parts and follow plans, but not how to fix.

Can anyone suggest where to start, what to look for?
Do you have a multimeter? Can you check supply voltage, amp output (DC with no signal) voltages?

Jan Didden
__________________
If you don't change your beliefs, your life will be like this forever. Is that good news? - W. S. Maugham
Check out Linear Audio!
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
argh what site was this! neutron7 Everything Else 7 18th February 2007 07:13 AM
Argh!! phn Tubes / Valves 12 4th November 2006 02:23 PM
Veneer bubbling- argh! tktran Multi-Way 3 27th June 2004 04:08 PM
Linn LK-2(60) One Channel has Failed. Anyone familiar with this circuit design? dtm1962 Solid State 0 11th April 2004 12:41 AM
Argh Otherwise Everything Else 1 10th March 2004 07:28 PM


New To Site? Need Help?

All times are GMT. The time now is 05:18 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2