Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Chip Amps Amplifiers based on integrated circuits

ARGH! One channel failed ... where to start?
ARGH! One channel failed ... where to start?
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 23rd July 2007, 12:43 PM   #1
paulspencer is offline paulspencer  Australia
diyAudio Member
 
paulspencer's Avatar
 
Join Date: Sep 2003
Location: Melbourne, Australia
Default ARGH! One channel failed ... where to start?

It's an ESP chip amp and one channel has failed. It happened when I stood on some cables, I heard a little zap, the sound cut out from one channel. I've checked cables and they all seem fine. I also can't see how I could have caused any fault.

Now I'm a little stuck. I know how to identify the parts and follow plans, but not how to fix.

Can anyone suggest where to start, what to look for?
  Reply With Quote
Old 23rd July 2007, 12:44 PM   #2
jan.didden is offline jan.didden  Europe
diyAudio Member
 
jan.didden's Avatar
 
Join Date: May 2002
Location: The great city of Turnhout, BE
Default Re: ARGH! One channel failed ... where to start?

Quote:
Originally posted by paulspencer
It's an ESP chip amp and one channel has failed. It happened when I stood on some cables, I heard a little zap, the sound cut out from one channel. I've checked cables and they all seem fine. I also can't see how I could have caused any fault.

Now I'm a little stuck. I know how to identify the parts and follow plans, but not how to fix.

Can anyone suggest where to start, what to look for?
Do you have a multimeter? Can you check supply voltage, amp output (DC with no signal) voltages?

Jan Didden
__________________
Music is dither to the brain; lets me think below the usual chaos - me
Get more Linear Audio for less! Check out my Autoranger and SilentSwitcher
  Reply With Quote

Reply


ARGH! One channel failed ... where to start?Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
argh what site was this! neutron7 Everything Else 7 18th February 2007 07:13 AM
Argh!! phn Tubes / Valves 12 4th November 2006 02:23 PM
Veneer bubbling- argh! tktran Multi-Way 3 27th June 2004 04:08 PM
Linn LK-2(60) One Channel has Failed. Anyone familiar with this circuit design? dtm1962 Solid State 0 11th April 2004 12:41 AM
Argh Otherwise Everything Else 1 10th March 2004 07:28 PM


New To Site? Need Help?

All times are GMT. The time now is 06:52 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 16.67%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki