Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

punch 401s problem
punch 401s problem
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 14th December 2006, 04:05 AM   #1
nu2this is offline nu2this  United States
diyAudio Member
 
Join Date: Dec 2006
Default punch 401s problem

the left channel has no output. there is no sign of damage and i checked the the big resistors beside the mosfets and they are all good. not real good with amp repairs yet. just started tring but it passes the time. i don't know much but if somebody could point me in the right direction i will read as much as it takes.
  Reply With Quote
Old 14th December 2006, 10:24 AM   #2
Hayden is offline Hayden  Australia
diyAudio Member
 
Join Date: Aug 2004
Location: Mackay Australia
Did it just die?
Was it working before?
even though components look fine on the outside they can be dead inside, trace the channel back to the output transistors and put your meter on diode and measure them in all combinations if their shorted they will show close to 000 thatís if its badly damaged or have a low impedance resister inline. the reason for the channel being dead could be anything, do an elimination check make sure its in the amp, swap cables and change sources fiddle with settings stuff like that, it could even be dry joints.
  Reply With Quote
Old 14th December 2006, 11:04 AM   #3
DigitalJunkie is offline DigitalJunkie  United States
diyAudio Member
 
Join Date: Apr 2003
Location: Portland,Oregon
Send a message via AIM to DigitalJunkie
Default Re: punch 401s problem

Quote:
Originally posted by nu2this
i don't know much but if somebody could point me in the right direction i will read as much as it takes.

In that case:
http://www.bcae1.com

Loads of reading!
  Reply With Quote
Old 14th December 2006, 12:31 PM   #4
nu2this is offline nu2this  United States
diyAudio Member
 
Join Date: Dec 2006
thanks for the replies and the link. the amp just quit. i think i will do the reading first. i like to understand things instead of jumping in. thanks again.
  Reply With Quote
Old 14th December 2006, 07:49 PM   #5
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Rockfords rarely fail where one channel just quits (completely dead, no static/distortion, no DC).

Did you try switching the RCA inputs (left/right) to confirm that it's not a signal input problem?

Did you try try swapping the speakers (left/right)?

Is there any DC voltage across the speaker terminals (black lead on negative speaker terminal, red lead on positive speaker terminal)?
  Reply With Quote

Reply


punch 401s problemHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fosgate P250.2 w/ 10" Punch P1 problem wpc Car Audio 10 15th June 2009 03:30 PM
Punch 45 - Weird Problem with Start-up bigphil Car Audio 5 30th December 2008 08:59 AM
Punch 200.4 PS problem? RJCRAFTS Car Audio 5 25th June 2008 02:21 AM
Selling a punch 250a2, old punch 75, and ppi epx 205 on EBAY ppia600 Swap Meet 0 23rd February 2008 02:17 AM


New To Site? Need Help?

All times are GMT. The time now is 05:47 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 16.67%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki