Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 17th October 2006, 03:19 PM   #1
diyAudio Member
 
Join Date: Sep 2006
Default kenwood kac 7202

hi im working on a kenwood amp kac 7202 and checked all the outputs the test fine amp turns on but the red light stays on all the time its in protecion mode what do i check next or how do i get it out of protection
  Reply With Quote
Old 17th October 2006, 04:38 PM   #2
sdoom is offline sdoom  Germany
diyAudio Member
 
Join Date: Mar 2004
Location: Heidelberg
wasn´t kenwood using the green light for ptotection ? I remember on my KAC-823 and KAC-1023 the red light indicated normal operation....
  Reply With Quote
Old 17th October 2006, 05:49 PM   #3
diyAudio Member
 
Join Date: Sep 2006
yeah im sorry the red light means its fine but the red light shuts off almost instantly meaning its going into protection wondering what else i check
  Reply With Quote
Old 17th October 2006, 05:54 PM   #4
sdoom is offline sdoom  Germany
diyAudio Member
 
Join Date: Mar 2004
Location: Heidelberg
Are all power transistors in the music-output section ok ? Usually you can test this with an ohmmeter when the amp is off. Check for shorts between the power transistor legs.

Usually there are always two transistors belonging to one channel, one is an NPN , the other the PNP transistor, on both types usually the center leg is the collector. Try to check resistance between the two collectors , if there´s always a short there might be broken power transistors or faulty rectifier diodes in the power supply section.

Also try to check resistance of each collector to speaker GND , again ther e must be no short there.
  Reply With Quote
Old 17th October 2006, 09:43 PM   #5
diyAudio Member
 
Join Date: Sep 2006
thanks for your help it had a blown transistor on the left channel replaced it and works fine thanks again
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kenwood KAC-X4R matdotcom2000 Car Audio 0 20th December 2007 02:36 PM
kenwood kac-715 purocolt Car Audio 5 4th September 2007 01:54 PM
Kenwood L-07D... bulgin Analogue Source 0 14th July 2007 07:18 PM
Which dac has this Kenwood? tubee Digital Source 5 22nd August 2006 07:34 PM
PLEASE! Kenwood help! mjarve Solid State 1 23rd September 2004 04:04 AM


New To Site? Need Help?

All times are GMT. The time now is 05:48 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2