diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Car Audio (http://www.diyaudio.com/forums/car-audio/)
-   -   Help-Car deck Doesn't work (http://www.diyaudio.com/forums/car-audio/82528-help-car-deck-doesnt-work.html)

jatminder 3rd July 2006 06:28 AM

Help-Car deck Doesn't work
 
Hey

I purchased a Kenwood (KDC-MP428) CD car deck 4-5 months ago. it was working fine untill yesterdsday, just didn't work. it has a Detachable Face so right now nothing comes on the detachable face. no light no power, nothing. cannot play anything, can't go to any menu. but when i open the face. there is eject button and also there is light blinks in it. it ejects the cd. so there is power. but i don't know why nothing comes on the screen (face). i don't know whats the problem.

please help me

Iíll really appreciate your help.

thanks for your time.

jatminder

Perry Babin 3rd July 2006 08:50 AM

If all of the power connections and fuses are OK, I'd suspect the ribbon cable that attaches the face to the main board. On the older Kenwoods with the flip-face, the failure rate is ~100% within 1 year (from my experience).

http://www.kenwoodparts.com/

jatminder 10th July 2006 08:13 AM

Car deck Doesn't work
 
yea, i checked all the connections, all were good but when i checked my car speakers, front left speaker was hanging down. i think that was the problem so fixed it and now my cd player works. but when i was opening the car door to fix the speaker, i broke a little hook was in the door. now i have to open my car door from outside, inside doesn't work. :(....

BUT THANKS ANYWAYS

I APPRECIATE UR HELP.


All times are GMT. The time now is 01:47 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2