Wierd problems with amp. - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 3rd August 2004, 09:57 PM   #1
diyAudio Member
 
Join Date: Aug 2004
Location: Bama
Question Wierd problems with amp.

Ok, ive recieved an amp the other day. Its a Jensen A300HLX 300 watt peak , 200x1 rms, 85x2 rms. Im running a pioneer tsw10c in a small truck. Anyway i know its not the best but i do belive jensen builds a good product for the money. So i recieved this amp from my uncle who has abuised it for 2 years, putting 2ohm load bridged ect. It only recently started cutting out on him so he gave to me for my lil 200watt pos amp. Ok so i hook it up and im drving down the road then all of a sudden, BOOOM BOOOM boom boom. The amp cuts off, or should i say its stays on but its playing like the gain is 1/3up and like the right or left input channel is unplugged. So everytime it cuts out like that i have to hit it or go over a bump, i only have to tap it to make it go back to normal. What could be wrong? I did open it up to see but no visable damn noticed from my eyes. Its getting very annoying and i'd like to get it repaired and not get a completey new amp. Afterall it does pound alot harder than my other one and i dont plan on buying anything but a new headunit in the next few months. Please help
  Reply With Quote
Old 4th August 2004, 12:25 AM   #2
Tensop is offline Tensop  Lebanon
diyAudio Member
 
Join Date: Jul 2003
Location: Chapel St.
dry joint or broken contact between a component and the PCB due to being a ****** driving around putting 5 billion watts through the subwoofer and annoying everyone
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wierd amp problem offroadbum Car Audio 4 2nd July 2007 12:09 AM
Wierd mixer problem.. Optical Solid State 14 16th February 2005 05:36 AM
wierd! check it out Illusus Everything Else 4 4th November 2004 05:14 AM


New To Site? Need Help?

All times are GMT. The time now is 04:30 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2