Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 20th July 2004, 07:21 AM   #1
diyAudio Member
 
Join Date: Jul 2004
Location: Cleveland Ohio
Exclamation Need Help With Orion 600 Amp!!!!

I have just installed my system in the car which is an orion 600 amp and two JL 12's and it thumped pretty good for some many hours. When i was driving back home on the freeway it turned off and me thinking it was just overheated. So when i got home and turned the car off to let it cool down for a few hours. Later on i turn the car back on to adjust the audio settings for later on use since i don't want to mess around with it while driving. When i turned the car on, the head unit turned on and the car speakers also turned on except my subs. So i checked in the back and found the amp wasn't blinking anymore like how it was in the beginning. The eyes were suppose to be blinking to the bass beats and right now only one eye is constantly on and the other one isn't. So i checked all the wires to see is everything still connected. Nothing wrong there. I also checked the fuse and it doesn't look like it's blown already. So is my amp blown or my sub blown? or is it just a minor problem that's easy to fix? Unless it's the fuses on the amp that's blown. I don't know, hopefully someone on here knows what's the problem with my stuff.
  Reply With Quote
Old 20th July 2004, 09:04 AM   #2
diyAudio Member
 
li_gangyi's Avatar
 
Join Date: Jun 2003
Location: Woodlands Circle
feed the headunit's signal straight to the amp...I assume u have an active crossover to get the subwoofer's frequencies...and also try another pair of speakers...might be a blown sub...
__________________
Kids in the back seat cause accidents...Accidents in the back seat cause kids...
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
orion 800.2 amp ampjunkielikeme Car Audio 7 13th April 2009 04:13 AM
First gen 250 Orion SS64 Car Audio 8 6th January 2009 01:10 AM
First Gen 225 Orion SS64 Car Audio 13 14th December 2008 11:54 PM
Orion 250 amp mike49504 Car Audio 11 21st November 2008 04:45 AM
Orion NT 200 vs Orion 2150 SX Clipped Car Audio 3 12th June 2007 01:55 PM


New To Site? Need Help?

All times are GMT. The time now is 11:58 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2