Broken Alpine - need help - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 9th June 2004, 10:39 AM   #1
diyAudio Member
 
Join Date: Jun 2004
Location: Wisconsin
Unhappy Broken Alpine - need help

Hello all. I have a question about what to do with a broken alpine amplifier (mrv-f407), which is in otherwise mint condition. Apparently one of my 6x9 wires was pulled down by a piece of luggage in my trunk, which shorted the + and - wires together. The amp immediately went into protect mode and blew my d-block fuse (30 Amp). The amp's "power" indicator light glowed constant red (should be green). I fixed the speaker wire, and put a new fuse in the d-block. It immediately blew again upon turning the head unit on. I had the amp checked out locally for $25. They told me 2 FET's required replacing and would cost $158. They said it was so much because the parts are hard to come by from Alpine. Does this seem right? Is there anywhere else I could get it fixed cheaper? It was about a $450 amp new retail, although I paid less online around 4 years ago. It would be a shame to see this amp wasted. I do not know what else to do with it though? Would someone who can fix it be willing to buy it for around $40-50? Any info would be appreciated. Thanks.
  Reply With Quote
Old 9th June 2004, 03:45 PM   #2
diyAudio Member
 
Paradise_Ice's Avatar
 
Join Date: Jun 2004
Location: cosmological consciousness
Dont worry, The Fet transistors are not that expensive and you can get them from any good radio spares shop, get a muitimetre and test the pins on the legs on all your transistors! the one with no reading is your goosed FET's you can desolder them yourself and replace them with the same fets yourself, Its not gonna cost you $140 bucks, if you find the blow fets and remove them the other channel should work, if a little distorted, but get the number of the fets and orders them and fix it yourself, it not that bad so cheer up!
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alpine MRD-605 no output cobology Class D 0 21st February 2009 01:45 AM
Alpine 5.25 Car Speakers FS vdi_nenna Swap Meet 0 11th December 2008 08:53 PM
is this an alpine amp? jol50 Car Audio 30 29th April 2008 04:11 AM
Alpine 3900 ahmisuhairi Car Audio 3 23rd October 2007 12:56 AM
PPI vs. Alpine smokeaway Solid State 2 28th August 2005 11:51 AM


New To Site? Need Help?

All times are GMT. The time now is 12:45 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2