Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Legacy LA470 repair help
Legacy LA470 repair help
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th May 2004, 11:45 PM   #1
tantulas is offline tantulas  United Kingdom
diyAudio Member
 
Join Date: May 2004
Location: Scotland
Default Legacy LA470 repair help

The first time the amp was ever hooked up, the polarity of the power was wrong(dont ask). No fuses blew , which i found strange, and smoke came from the LA470.
The LA470 has some sort of protection circuitry and a red LED lights when active- this LED is now permantly on and i cant disable it, theres no reset. Chances are the amp is fried somehow and thats why its staying on, can any one help!?
  Reply With Quote

Reply


Legacy LA470 repair helpHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Have legacy audio got it right? paulspencer Multi-Way 13 7th July 2005 11:10 PM
Legacy GC with new snubber PS budwiser Chip Amps 141 20th March 2005 07:20 PM
Re: Advent Legacy II's? Tell me all you know... JeremyD Multi-Way 9 12th May 2003 02:09 AM


New To Site? Need Help?

All times are GMT. The time now is 06:10 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 16.67%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki