Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Rockford punch 600a4
Rockford punch 600a4
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 20th June 2018, 10:58 PM   #1
rhempz01 is offline rhempz01  United States
diyAudio Member
 
Join Date: Nov 2016
Location: Milford Delaware
Default Rockford punch 600a4

Just came in and was only drawing .56amps of current, stuck in protection. All the buz272/buz21 check good. Power supply is good. So I found a few driver transistors were missing from the board. I replaced them and now it draws 1.81amps of current and rear channel are working and the front does not unless in 2channel mode I get a crazy looking signal only on the fleft.
Attached Images
File Type: jpg 15295350314067115737575836910428.jpg (1.01 MB, 63 views)
  Reply With Quote
Old 20th June 2018, 11:01 PM   #2
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Broken RCA shields?
  Reply With Quote
Old 20th June 2018, 11:44 PM   #3
rhempz01 is offline rhempz01  United States
diyAudio Member
 
Join Date: Nov 2016
Location: Milford Delaware
I'll check, perry. I don't think so I can see the 50hrtz u300 going in but not out. And I think u400 appears burnt.
  Reply With Quote
Old 21st June 2018, 01:10 PM   #4
rhempz01 is offline rhempz01  United States
diyAudio Member
 
Join Date: Nov 2016
Location: Milford Delaware
Perry do you know what those parts are lm3?? Are the dual op amps? They are faded off. Lm358?
  Reply With Quote
Old 21st June 2018, 02:19 PM   #5
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
What's the PC# on the board? The similar diagrams I have show TL072 in all locations but the attached photo has LM833s.
  Reply With Quote
Old 21st June 2018, 02:37 PM   #6
rhempz01 is offline rhempz01  United States
diyAudio Member
 
Join Date: Nov 2016
Location: Milford Delaware
Do you think the tl072 will work if I replace them all? I will haft to pull both data sheets to see what the differences are.
  Reply With Quote
Old 21st June 2018, 02:46 PM   #7
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
With op-amps, the datasheets may not be 100% reliable in determining what will/won't be compatible. In this amp, the TL072 will likely be OK. If nothing else, they will be OK for testing.

Make sure the regulated voltage is not excessive before replacing any of the op-amps.
  Reply With Quote
Old 21st June 2018, 03:27 PM   #8
rhempz01 is offline rhempz01  United States
diyAudio Member
 
Join Date: Nov 2016
Location: Milford Delaware
If I change them, would I need to change them all or just the damaged components?
  Reply With Quote
Old 21st June 2018, 03:31 PM   #9
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
I don't know what caused the damage. If the regs failed and drove full rail to all of them, reliability may be an issue with all of them. I'd start by replacing the ones known to be defective.
  Reply With Quote
Old 21st June 2018, 08:16 PM   #10
rhempz01 is offline rhempz01  United States
diyAudio Member
 
Join Date: Nov 2016
Location: Milford Delaware
They are all testing ok to me. It drawing current now so I believe the mosfets on the front side are bad in the output section. In place if the buz21/buz272, use irfp540 and irfp9540? I'm changing the drivers first maybe some are leaking
  Reply With Quote

Reply


Rockford punch 600a4Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rockford Fosgate 600a4 S Merlington Car Audio 4 3rd February 2016 03:41 AM
Rockford Fosgate 600A4 S Merlington Car Audio 3 29th August 2015 05:48 AM
rockford 600a4 DREW028 Car Audio 9 9th April 2012 11:48 PM
punch 600a4 ian33 Car Audio 26 29th September 2011 05:01 PM
Rockford fostgate 600a4 OneLostSoul Car Audio 13 29th August 2009 11:36 PM


New To Site? Need Help?

All times are GMT. The time now is 04:33 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 14.29%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki