Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Performance Teknique ICBM-9550
Performance Teknique ICBM-9550
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 5th July 2018, 01:11 PM   #11
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
If the relay is switching on and off for muting, how are you getting a pop?
  Reply With Quote
Old 5th July 2018, 05:45 PM   #12
Formas is offline Formas  Jamaica
diyAudio Member
 
Join Date: May 2008
I am getting a pop, i have no idea. is there any fixed setting on the relay circuit that should open the relay before the system is actually "off" as its delayed when turning on the amp (about 2 seconds click when remote is been applied) it closes?
Im currently ordering some caps for the op amp voltages and caps CX6 and CX7 i havent replaced them yet to do more tests.
Could you tell me the value of resistor RA10 and RA11? (is it 2.2ohms or 3.3ohms)?
  Reply With Quote
Old 5th July 2018, 05:55 PM   #13
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
The relay should open immediately when remote is removed. The 2 second on-delay may be a bit too short.

Are the relay contacts welded preventing from opening?

The resistors appear to be 2.2 but the marking isn't what you'd commonly see. See attached.
Attached Images
File Type: jpg P4120010x.jpg (179.0 KB, 12 views)
  Reply With Quote
Old 11th July 2018, 09:04 PM   #14
Formas is offline Formas  Jamaica
diyAudio Member
 
Join Date: May 2008
The amplifier is fine now, the four caps I ordered makes it right I think there was a swing or a spike in the voltages either on the opamp rail (35v 1000uf) or the smoothing rail caps (200v 33uf) when the amp powers on or off.
Is there any know tester or test procedures that can use to definitely know when a cap is bad? As fixing this amp the capacitors was tested good on my Fluke 115 and also my capAnalyzer? And too many times Iím been thrown off by bad caps that just simple reads good.
Attached Images
File Type: jpeg DCEC338C-AC70-4E29-80FE-A420F2A53CFA.jpeg (786.8 KB, 6 views)
  Reply With Quote

Reply


Performance Teknique ICBM-9550Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
performance teknique amp icbm 9550 ian33 Car Audio 39 3rd July 2018 01:04 AM
Question on inductor repair Performance Teknique ICBM-Digita jacampb2 Car Audio 3 2nd August 2017 05:20 PM
Performance Teknique ICBM-DIGITAL Protect Mode JP503 Car Audio 8 2nd December 2016 10:33 PM
ICBM 9550 ian33 Car Audio 0 14th July 2016 12:32 AM
Performance Teknique ICBM-771 mike49504 Car Audio 1 10th November 2011 05:13 AM


New To Site? Need Help?

All times are GMT. The time now is 06:18 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki