Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

NEED HELP!  Phoenix gold ms-275  schematic
NEED HELP!  Phoenix gold ms-275  schematic
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 5th February 2018, 06:47 PM   #1
Chesley is offline Chesley  United States
diyAudio Member
 
Join Date: Feb 2018
Default NEED HELP! Phoenix gold ms-275 schematic

I have an old phoenix gold MS 275 that Iím trying to repair. I cannot find them real schematic anywhere online. Only a hand-drawn schematic that does not cover the whole motherboard. Iíve tried to contact phoenix gold and they will not release any schematics. Does anybody happen to have the schematic if so please email me at Chesleyshapiro@gmail.com thank you for any help
  Reply With Quote
Old 5th February 2018, 07:12 PM   #2
NadaD is offline NadaD
diyAudio Member
 
Join Date: Oct 2017
Whats wrong with it?
Maybe someone can help.
  Reply With Quote
Old 5th February 2018, 09:20 PM   #3
Chesley is offline Chesley  United States
diyAudio Member
 
Join Date: Feb 2018
At first one channel seem to be blown. Getting staticy low sound. Started trying to fix it opened it up the channel I was having problems with the two red LED lights were not on on that side Having a hard time tracking down the problem without a schematic.
  Reply With Quote
Old 8th February 2018, 09:57 PM   #4
Chesley is offline Chesley  United States
diyAudio Member
 
Join Date: Feb 2018
Update to problem.
good evening fellas I’m hoping somebody can help me out today after learning that it is pretty much impossible to get the electrical schematic for this a.m. I’m wondering if anybody here on this form can help? On my 275 I had a blown right channel. Static he sound in very low volume out of that right side. My father‘s good friend is an electrical engineer so we opened up the M check the fuses everything looked OK except that on that right channel the two red LED lights were not on. The two red LEDs on the left channel were on in that channel worked fine. He pulls out his Ossola scope (not sure if that’s how you spell it probably not. Big machine that he used probes to poke around the motherboard). Also we were using a hand-drawn schematic the only one I could find on the Internet while trying to test these components. While he was comparing the good side to the bedside trying to track down the problem he touched something and two red LEDs on the good channel went off and did not come back on. Also I noticed originally on power up the red overload light would come on first then go out and then the green power light would come on. Now that both channels LEDs were not coming on on power up it went straight to green power light. It was around this time that he said this was not the right schematic. So this is the dilemma I am in hopefully somebody on here has the knowledge to at least walk me through what the test to see if it’s bad. He was thinking it went into protection mode however we cannot figure out that circuit. Any help would be greatly appreciated. Thank you all for your time.
Chesley Shapiro
  Reply With Quote
Old 11th February 2018, 04:51 PM   #5
Bertje is offline Bertje  Netherlands
diyAudio Member
 
Join Date: Jan 2004
Location: Holland
First check all the fusible resistors (gray/green color), driver transistors and bigger output transistors. The leds itself could be defect.
This amps suffering from leaky filter capacitors, 3x 2200uF/16V in the middle of the board. If they aren't exchanged yet, you have to do that also.
  Reply With Quote
Old 12th February 2018, 11:39 PM   #6
Chesley is offline Chesley  United States
diyAudio Member
 
Join Date: Feb 2018
Awesome thank you
  Reply With Quote
Old 17th February 2018, 02:30 AM   #7
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
There is a link on this page.
phoenix gold mps-2240 schematics
  Reply With Quote

Reply


NEED HELP!  Phoenix gold ms-275  schematicHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Phoenix Gold?? rhempz01 Car Audio 12 19th November 2017 11:38 PM
Phoenix Gold M44 Schematic or Help Please 86boy Car Audio 8 6th June 2014 12:46 AM
phoenix gold zx500 schematic elchino10 Car Audio 3 28th November 2013 12:13 AM
Phoenix Gold Titanium 1200.1 schematic diagram Staykov Car Audio 0 10th December 2011 03:15 PM
Phoenix Gold ZPA 0.5 Bertje Car Audio 9 16th December 2010 03:11 PM


New To Site? Need Help?

All times are GMT. The time now is 05:16 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki