Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Soundstream STL1.1200D
Soundstream STL1.1200D
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th December 2017, 07:26 PM   #1
mild2wild is offline mild2wild  Trinidad and Tobago
diyAudio Member
 
Join Date: Nov 2014
Default Soundstream STL1.1200D

Need some help with one of these monoblocks. There are many clones going by many names so hopefully there should be a lot of knowledgeable help available. I received two, both need repair. One works but had distorted output, while the other didn't power up at all. We will start with the semi-functional one and maybe I can repair the second one by myself once I have a proper working amp as reference. I am ordering some parts and would like to know what should I order just to be sure to have any possible replacement parts on hand.

I need to know what transistor at Q17 connects to pins 11 and 12 of the TL494?

Is U14 the optocoupler that can be replaced with a 6N137?

What else should I order that may need replacement in this/these amplifier(s)?
Attached Images
File Type: jpg IMG_20171212_154729.jpg (457.1 KB, 55 views)
File Type: jpg IMG_20171212_154646.jpg (671.7 KB, 55 views)
File Type: jpg IMG_20171204_232248.jpg (807.1 KB, 52 views)
  Reply With Quote
Old 12th December 2017, 07:30 PM   #2
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
http://www.bcae1.com/temp/SLA1500.pdf
  Reply With Quote
Old 8th February 2018, 10:44 PM   #3
ray9043 is offline ray9043  Mexico
diyAudio Member
 
Join Date: Mar 2008
Hey, can you fix it?? I have the same problem,, i replace the optos with 6n137, but maybe it need to have NOT output. The original parts are scratched, and the diagrama from perry dont has the ic number-name.
  Reply With Quote
Old 9th February 2018, 08:00 AM   #4
MarioRestucci is offline MarioRestucci  Italy
diyAudio Member
 
MarioRestucci's Avatar
 
Join Date: Aug 2012
Location: NAPOLI
I confirm, the scratched IC is 6N137.
to repair this type of amp, an oscilloscope is necessary!
It is necessary to check if there are correct signals on the gates of each output device, before installing the new mosfets.
To do this, it is advisable to remove the rectifiers, using as reference (always) the source pad of the mosfet concerned and injecting a 100hz strong signal at the input of the amplifier (turning the potentiometer of the LPF and GAIN at maximum and excluding any subsonic filter and / or bass boost).
  Reply With Quote

Reply


Soundstream STL1.1200DHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Orion 1200D Deadly Sones Car Audio 8 2nd April 2015 05:29 PM
Orion 1200D S Merlington Car Audio 10 2nd August 2012 05:06 AM
Help with Sundown SAE-1200d notoriousJ Class D 0 19th April 2011 01:40 PM
Audioque 1200d? eastman474 Car Audio 2 9th September 2009 11:06 PM
Audioque 1200d? eastman474 Class D 3 29th August 2009 12:40 AM


New To Site? Need Help?

All times are GMT. The time now is 11:20 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki