Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 29th March 2004, 06:55 PM   #1
diyAudio Member
 
Join Date: Mar 2004
Location: Cola, SC
Default Fried Orion 250HCCA

Wazzup Ya'll! New to this board, looks like maybe I can get some good ideas though! I just got an Orion 250HCCA from a friend for a good deal, but turns out it's not working. I have taken the board out of the heat sink and looked around, and everything seems to be in pretty decent shape, but I haven't used a DMM yet. I had a 225HCCA back in the day, and ran it at 1 ohm all day and never had any probs. I guess I am just curious if any one in here has had experience with these(or any other) amps, and what could possibly be the problem. Thanks :beer:
  Reply With Quote
Old 29th March 2004, 07:02 PM   #2
Netlist is offline Netlist  Belgium
diyAudio Moderator Emeritus
 
Netlist's Avatar
 
Join Date: Jan 2003
Default Re: Fried Orion 250HCCA

Quote:
Originally posted by TLRacer415
...but I haven't used a DMM yet.
Hi Racer and welcome.
Try to use your DMM and tell us what it told you
  Reply With Quote
Old 29th March 2004, 08:31 PM   #3
diyAudio Member
 
Join Date: Mar 2004
Location: Cola, SC
Will do
  Reply With Quote
Old 5th April 2004, 03:06 AM   #4
pkmaven is offline pkmaven  United States
diyAudio Member
 
Join Date: Apr 2004
Location: Massachusetts
Default Orion HCCA

I used to be the rep for Orion in new England. None of the people who worked atthe facility that built your amp are there anymore. The engineer who designed the HCCA amps went to work at Cerwin-Vega and designed their amps. If I had your amp, I would call Orion (now owned by Directed Electronics-the name Orion as well as the name Precision Power and also ADS) in Tempe, Az. and ask if they can fix it. It is definitely worth it. P.
  Reply With Quote
Old 22nd April 2004, 02:20 AM   #5
peet is offline peet  Thailand
diyAudio Member
 
Join Date: Mar 2004
Location: Bangkok, Thailand
The capacitors may expire. try to check them.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fried T-Amp? Bingobing Class D 11 2nd November 2010 02:12 AM
Orion NT 200 vs Orion 2150 SX Clipped Car Audio 3 12th June 2007 01:55 PM
Fried X-over Zen Mod Multi-Way 24 24th November 2006 12:12 AM
Fried t-amp? kaban Class D 24 23rd June 2006 09:03 AM
$5 SE amp... but is it fried?! SHiFTY Tubes / Valves 3 18th January 2004 03:13 PM


New To Site? Need Help?

All times are GMT. The time now is 04:05 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2