Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Xenon 11.5k amplifier output card driver
Xenon 11.5k amplifier output card driver
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 15th August 2017, 05:34 PM   #11
jlind54 is offline jlind54  United States
diyAudio Member
 
Join Date: Nov 2012
Location: Kansas
Make sure the resistors near the driver card are all in spec. There are some 1ohm or 4.7ohm resistors that sometimes open with no visible damage. With one defective the outputs will continue to fail when powered up until replaced. Are you using a new driver card, or have you replaced the 21844's on that one?
  Reply With Quote
Old 17th August 2017, 09:29 PM   #12
Tom7227 is offline Tom7227  United States
diyAudio Member
 
Tom7227's Avatar
 
Join Date: Dec 2006
Location: Buffalo, New York
Xenon 11.5k amplifier output card driver Send a message via AIM to Tom7227
Actually, the amp works. The owner was using it, but one side of the amp gets hot very quickly. With no speaker connected.

I just found one the 2 inductors, had one connection totally burned off the PCB, no electrical connection at all.

This is the side that was overheating, but I am pretty convinced the Mosfets (24N50) , were overheating.

Do you think the Mosfets would overheat if no connection to the inductor?
Attached Images
File Type: jpg Inductor Flatline.jpg (436.5 KB, 45 views)
  Reply With Quote
Old 18th August 2017, 01:29 AM   #13
Tom7227 is offline Tom7227  United States
diyAudio Member
 
Tom7227's Avatar
 
Join Date: Dec 2006
Location: Buffalo, New York
Xenon 11.5k amplifier output card driver Send a message via AIM to Tom7227
I will answer my own question.

The Mosfets overheated like mad before I fixed the inductor. The amp drew 104 amps idle, yet still functioned.

After repairing the inductor, amp is cool, and draws 22 amps idle.
  Reply With Quote
Old 18th August 2017, 01:36 AM   #14
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Are you sure that there wasn't a short as well? One small section of heatshrink looks like it got hot.
  Reply With Quote
Old 18th August 2017, 11:58 AM   #15
Pulse-R is offline Pulse-R  Australia
diyAudio Member
 
Join Date: Mar 2005
Location: Melbourne
I have a new board as well as the repaired one. Haven't had a chance to look back at it yet.
Will reverse engineer the board once I get time.
__________________
Digital is only on or off
  Reply With Quote
Old 18th August 2017, 04:13 PM   #16
Tom7227 is offline Tom7227  United States
diyAudio Member
 
Tom7227's Avatar
 
Join Date: Dec 2006
Location: Buffalo, New York
Xenon 11.5k amplifier output card driver Send a message via AIM to Tom7227
Perry,

I didn't see evidence of that, I wish I would have thought to take a picture of the condition before I pulled the wire off the PCB.

I did ohm the coil to the PCB, totally open, and the coil read 80uh. I would not have expected that disconnection of the circuit, would have caused the overheating condition either.

Let me tell ya, an amp drawing 102 amps while troubleshooting isn't exactly in my comfort zone.
  Reply With Quote
Old 16th November 2017, 12:24 PM   #17
Pulse-R is offline Pulse-R  Australia
diyAudio Member
 
Join Date: Mar 2005
Location: Melbourne
Thanks Perry.
Amp is fixed. Runs at 70kHz or so.
Problem was the megohm resistor on the driver card not soldered properly ( from new possibly) which prevents the saw wave oscillating.
5A draw at idle, 12v supply.
Cheers
Simon.
__________________
Digital is only on or off
  Reply With Quote

Reply


Xenon 11.5k amplifier output card driverHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Output driver card rrae Car Audio 7 1st August 2017 08:15 AM
Help identify IC - YEUM1007A output driver card Troy Dionne Car Audio 5 17th December 2016 04:35 AM
hi help about output driver card hadidin Car Audio 4 13th April 2016 08:07 PM
DDz1 Output driver (card) diagram rstone2 Class D 0 16th December 2014 01:39 AM
Diablo 2500.1 output driver card brandes.cm Car Audio 6 14th May 2012 01:44 AM


New To Site? Need Help?

All times are GMT. The time now is 05:45 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 14.29%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki