Need help with Concept Audio ccd-2400 amplifier - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 17th January 2004, 01:18 AM   #1
diyAudio Member
 
Join Date: Jan 2004
Location: New Mexico
Unhappy Need help with Concept Audio ccd-2400 amplifier

I got a Concept Audio ccd-2400 amplifier from one of my friends because it was not working, when I opened it up 12 mosfets on one side were fried. Most of the mosfets had the source leg blown off. I replaced all of them with the same part number as the original (FQP 50N06) and powered on the unit, but the mosfets were burned once again within seconds of turning it on. What could be causing this? Do I have to check each component individually?
  Reply With Quote
Old 17th January 2004, 03:36 PM   #2
maylar is offline maylar  United States
diyAudio Member
 
Join Date: Jun 2003
Location: Connecticut
I wouldn't even attempt to go any further without a schematic. You need to check the driver stages and both sides of the output circuits.
__________________
dave
  Reply With Quote
Old 5th February 2004, 10:40 PM   #3
diyAudio Member
 
EnvisionAudio's Avatar
 
Join Date: Apr 2002
Location: Dayton, OH
Default Whew!

A schematic won't help here - you need to know what you're doing first.

Blowing PS transistors is almost always caused by shorted outputs or a dead shorted free wheeling diode. Use your noggin and fix it again. Nothing like a nice expensive mistake to set you on your way.

I've been fixing car audio amps for years without schematics. In fact, I don't even own one schematic in my shop. I also build them...no, they're not for sale.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
PSL Ve 2400 amplifier Janne1 Solid State 2 26th May 2014 08:50 PM
SAE 2400 amp needs help scm Solid State 8 2nd July 2007 10:08 PM
Nad 2400 SillyCone Solid State 4 30th June 2007 08:32 PM
SMALA Amplifier concept rtarbell Solid State 4 7th February 2006 07:26 PM
The ChipSET - A Concept Chip Amplifier Steve Eddy Chip Amps 27 26th April 2005 11:42 PM


New To Site? Need Help?

All times are GMT. The time now is 06:36 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2