Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 5th February 2014, 12:39 AM   #1
diyAudio Member
 
Join Date: Jun 2011
Location: Manila
Default Power supply for 9KW rms amp and the driver board

Hello! Good day!

I repairing 9KW rms amp and goes to protect mode after blue light.

I removed the DLM4000 driver boards with DLI4060 proprietary IC but still on protect mode.

On this situation, I may say that driver board is not a problem? I know most of the amps powered on even no driver board/s installed? except there's a problem in the main board.

Also do I have sufficient power for my power supply? my power supply is just 6 Amps and 13.6V.
Without load and input signal, is it enough to power this monster amp?

Thank you very much!

Last edited by nonprof; 5th February 2014 at 01:51 AM.
  Reply With Quote
Old 5th February 2014, 01:16 AM   #2
ultra is offline ultra  Greece
diyAudio Member
 
ultra's Avatar
 
Join Date: Jun 2005
Location: Athens
Do you measure any DC voltage before the output relays?
Upon powering up, does your power supply voltage increase slowly?
These amps idle around 8 to 9A.
  Reply With Quote
Old 5th February 2014, 01:47 AM   #3
diyAudio Member
 
Join Date: Jun 2011
Location: Manila
Quote:
Originally Posted by ultra View Post
Do you measure any DC voltage before the output relays?
Upon powering up, does your power supply voltage increase slowly?
These amps idle around 8 to 9A.

Yes it raise not less than +-60VDC then protects, I think prior relay click protect turn on. I didn't check the voltage yet. Ok ill do that.

But I removed the driver boards already:-(( Can I make it blue light without driver boards?
  Reply With Quote
Old 5th February 2014, 02:26 PM   #4
Tom7227 is offline Tom7227  United States
diyAudio Member
 
Join Date: Dec 2006
Location: Buffalo
Send a message via AIM to Tom7227
I might have a schematic for that amp, and I was able to purchase the driver pcb's.
  Reply With Quote
Old 5th February 2014, 02:35 PM   #5
JMFahey is offline JMFahey  Argentina
diyAudio Member
 
JMFahey's Avatar
 
Join Date: Mar 2009
Location: Buenos Aires - Argentina
9KW RMS from puny +/-60V rails?
IMPOSSIBLE
  Reply With Quote
Old 5th February 2014, 02:38 PM   #6
JMFahey is offline JMFahey  Argentina
diyAudio Member
 
JMFahey's Avatar
 
Join Date: Mar 2009
Location: Buenos Aires - Argentina
Quote:
Originally Posted by nonprof View Post
I repairing 9KW rms amp
......................

Also do I have sufficient power for my power supply? my power supply is just 6 Amps and 13.6V.
You-must-be-joking
  Reply With Quote
Old 5th February 2014, 11:34 PM   #7
diyAudio Member
 
Join Date: Jun 2011
Location: Manila
Quote:
Originally Posted by JMFahey View Post
You-must-be-joking
I dont know i'm asking...

thats why im here looking for expert and some very nice people around here...
  Reply With Quote
Old 5th February 2014, 11:36 PM   #8
diyAudio Member
 
Join Date: Jun 2011
Location: Manila
Quote:
Originally Posted by Tom7227 View Post
I might have a schematic for that amp, and I was able to purchase the driver pcb's.

This is good news! can you share your schematics?

Thank you!
  Reply With Quote
Old 5th February 2014, 11:40 PM   #9
ultra is offline ultra  Greece
diyAudio Member
 
ultra's Avatar
 
Join Date: Jun 2005
Location: Athens
Quote:
Originally Posted by JMFahey View Post
You-must-be-joking
9Kw amps like DD Z2, american bass VFL 1000.1 etc, have around +/-168V rail voltage.
Nonprof never said rail voltage was +/-60V.
  Reply With Quote
Old 5th February 2014, 11:40 PM   #10
kevinkr is offline kevinkr  United States
diyAudio Moderator
 
kevinkr's Avatar
 
Join Date: Sep 2004
Location: Boston, Massachusetts
Blog Entries: 6
I suspect you need a much bigger power supply.. The idle current in such an amplifier must be greater than the rated current of your supply.

I just can't imagine 9kW, that would require something like 1000A from the car's electrical system.
__________________
"Extraordinary claims require extraordinary evidence." - Carl Sagan
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Amp pcb with on board power supply! jerryo Solid State 10 19th December 2013 11:02 AM
Lateral MOSFET power supply and RMS output power. tallerseverino Solid State 29 25th March 2012 04:32 PM
Sure amp board power supply? emilime75 Class D 2 23rd February 2012 11:40 PM
core power ratings for 9kW DCDC stuartsjg Power Supplies 36 19th July 2008 08:57 PM
does someone know the max rms power rating of the Blueprint 1503 driver? pkgum Multi-Way 3 9th December 2001 01:50 PM


New To Site? Need Help?

All times are GMT. The time now is 11:01 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2