Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

System Pictures & Description
System Pictures & Description
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 26th March 2017, 11:21 PM   #11
reloader650 is offline reloader650  United States
diyAudio Member
 
Join Date: Apr 2010
Location: Utah
Quote:
Originally Posted by dukecv View Post
I used to have a Precision Power Pro flat piston 12". That thing was sweet.
I always wanted a pair of the 12"s. In fact I'm still kicking myself because last year a pair of them came up for sale in the local classifieds. They sold before I could get them. I had 3 of the 10"s, but sold two and kept the one. Still lovin it.

Regards,
Matt
  Reply With Quote
Old 26th March 2017, 11:57 PM   #12
reloader650 is offline reloader650  United States
diyAudio Member
 
Join Date: Apr 2010
Location: Utah
Had a little time to kill today, so I decided to work on the sub box for my Dodge truck. Last year I finished the box, but didn't have time to install it. Too many projects not enough time. I started the box by making a template of the opening of the storage well. Then laid one layer of fiberglass to get a mold of the well. Pulled the mold out of the truck to lay 4 more layers of mat. Then I attached the top with epoxy and screws. I finished the box with a spray on truck bed liner, the finish seems to hold up well. For safety I wanted the box bolted down, so I fabricated brackets that use the factory bolt locations to hold it in place. The subwoofer is a fi audio Q series 10" with all the options. That's all I have for today. More to come, hopefully sooner than later.

Regards,
Matt
Attached Images
File Type: jpg IMG_1205.jpg (748.1 KB, 125 views)
File Type: jpg IMG_1204.jpg (952.3 KB, 120 views)
File Type: jpg IMG_1202.jpg (788.0 KB, 112 views)
File Type: jpg IMG_1203.jpg (825.4 KB, 107 views)
  Reply With Quote
Old 5th January 2018, 01:02 PM   #13
ResonateEngineering is offline ResonateEngineering
diyAudio Member
 
Join Date: Jan 2018
Here is my work in my work in progress.....delayed from winter and car accident.

Bought everything new at once for the install and only got half way through and smashed the car. Now I have boxes of audio goodness just waiting to be installed.

Optima battery up front, I used 4 runs of 4ga pure copper wiring for main power run to a central distribution, from there are it turns into 2 runs of knukonceptz 0ga back to another fused distribution then 0ga to both amps. I used all Stinger premium hardware, distribution, grounds, wire reducers etc. The grounds are compromised of 4 runs of knuconceptz 4ga to distribution then 2 runs of 0ga to amps. Added additional grounds at front battery and did big 3 up grade with copper wire. Have a nice shiny 250amp alternator ready to go.

New alpine head unit mounted. Decided to finally invest in decent rca cables so I picked up sky high car audio premium cables in a 4 channel and 2 channel braid.

For sound I have RE Audio 6.5 components in doors, dynomat in doors, foam baffle for sub.

In the backseat there are 2 coaxial 6.5 drivers and 2 RE Audio 2.5 high energy tweets.

In the trunk I built and carpeted the enclosure but will soon be redoing it.

2 RE Audio sx 10s (the good ones from pre sellout) should take a clean 2k each!

1 RE Audio 65kv.1 monoblock pushing subs.

1 RE Audio 4250 for the mids and highs.

Still have alot to do so stay tuned, I am dying to hear this in action. Looking for a sql result as I feel I have conquered the spl with my last build....
  Reply With Quote

Reply


System Pictures & DescriptionHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
System Pictures & Description kctess5 Subwoofers 164 12th June 2018 04:00 AM


New To Site? Need Help?

All times are GMT. The time now is 08:20 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki