JL 300/2 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 26th October 2013, 07:13 PM   #1
diyAudio Member
 
PapaZBill's Avatar
 
Join Date: Oct 2013
Location: Yale, Oklahoma
Default JL 300/2

I have a question about this amp. The low impedance lamp is lit. The install and speakers are checked out and the amp was swapped with another 300/2 and works fine with existing install and speaker system.The problem is in the amp. I work on amps for a living, but am not familiar with this amp.I appreciate any advice.Is it possible to get service schematics? I do not have the amp on hand and helping a friend fix amp remotely.
  Reply With Quote
Old 26th October 2013, 10:03 PM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
That's generally an indication that the amp has shorted outputs.

It's unlikely that you'll find schematics for the amp.
  Reply With Quote
Old 28th October 2013, 06:28 PM   #3
diyAudio Member
 
PapaZBill's Avatar
 
Join Date: Oct 2013
Location: Yale, Oklahoma
are you famaliar with this amp and do you know what the output devices are, by any chance?
  Reply With Quote
Old 28th October 2013, 06:42 PM   #4
diyAudio Member
 
PapaZBill's Avatar
 
Join Date: Oct 2013
Location: Yale, Oklahoma
I find a thread relating to this JL amp and found out the output mosfets are IRF540. I will check with digikey. Question, do you recommend replacing all of the output mosfets or just the shorted ones?
  Reply With Quote
Old 28th October 2013, 07:01 PM   #5
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
I recommend replacing all of the outputs in the blown channel. I wouldn't replace the others unless there were signs of abuse/overheating of the other transistors.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
JL 300/4 help please! qsilvertwo Car Audio 18 19th July 2012 09:14 PM
JL Audio 10w6v2 or Infinity Kappa 100.3se? Audison SRX4 or Jl 300/4? DcMaN Subwoofers 1 17th September 2010 11:28 AM
JL Audio 300/4 PQatPIT Car Audio 5 4th March 2009 03:06 PM
jl audio 300 2 ppia600 Car Audio 2 6th April 2008 04:54 PM


New To Site? Need Help?

All times are GMT. The time now is 08:41 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2