Alpine MRV-T503 Repair Help - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 25th September 2013, 11:14 PM   #1
diyAudio Member
 
Join Date: Apr 2013
Location: Geogia
Default Alpine MRV-T503 Repair Help

I have an Alpine MRV-T503 to repair and I'm wondering if anybody has a schematic for this amp so I can replace burnt parts. It appears the following is burnt:
* R501
* Q901
* R903
* R904
* And the two bigger capacitors next to the burnt parts are swollen

Any help would be great! Thanks!



Here's some pictures to help:
Click the image to open in full size.
Click the image to open in full size.
Click the image to open in full size.
Click the image to open in full size.
Click the image to open in full size.
  Reply With Quote
Old 26th September 2013, 05:18 AM   #2
diyAudio Member
 
Join Date: Dec 2005
Location: Northern California
Looks like your amp was hooked up backwards to power and ground. large caps are bad and need to be replaced, along with a bunch of other things most likely.
I don't have the schematic but its available form some of the pay schematic services on the net I'm fairly sure. You will have to pull the board out of its case but I am thinking you will have flashed open trace or two on the bottom of the board < something had to give up when it was failing like this >

Power supply power devices might also be burnt, along with PWM chip and voltage comparator circuitry.
I'm actually old enough to remember this amp new so, I have seen a few with your troubles before. Its fixable, but not an easy repair due to PC board damage and such. I have also seen this when the supply power devices shorted out, so its either or that caused this.

Have you ohm'ed out the power devices clamped to the sink on the edge of the card??? I would before treading too much farther. And google search the web for the schematic, You can start by trying here first:
Manual-Archives | Service Manuals & Schematic Diagrams

Hope this helps some...
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alpine MRV-1000 repair Kei Car Audio 7 28th July 2013 12:08 PM
Alpine MRV-1000 repair questions spooney Car Audio 40 28th July 2013 12:05 PM
Alpine MRV 1507 FSUSeminole Car Audio 8 1st January 2011 08:04 PM
Alpine MRV-F401 or MRV-F400 Service Manual M.André Car Audio 6 21st February 2010 10:37 PM
Seeking input on repair of Alpine MRV-F400 amp Nagamitsu Car Audio 7 23rd April 2009 07:48 PM


New To Site? Need Help?

All times are GMT. The time now is 12:34 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2