Kicker ZX1500.1 gate drive problem - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 5th June 2013, 09:17 PM   #1
diyAudio Member
 
Join Date: Jun 2002
Location: non
Default Kicker ZX1500.1 gate drive problem

Blown up, replaced power supply transistors, drivers, and the driver IC.

Only getting about a volt or so of gate drive on power supply, and 2.5VDC sitting on the gates.

so of course, the SMPS gets really hot super fast and drawing excessive current.

any ideas?
  Reply With Quote
Old 5th June 2013, 10:57 PM   #2
diyAudio Member
 
Join Date: Jun 2002
Location: non
Found the problem, C25 was bad.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kicker ZX1500.1 without gate drive. Randy62 Car Audio 7 29th May 2013 05:47 PM
kicker zx1500 mosfet question ksweet420 Car Audio 9 11th March 2013 09:12 PM
Kicker zx1000.1 gate resistor values bigpun4fubu Car Audio 1 16th November 2011 12:37 AM
kicker zx1500.1 output inductor? shane300zx Car Audio 9 2nd August 2011 08:58 AM
Kicker zx1500.1 not working Andrew123654 Car Audio 12 19th October 2010 12:04 PM


New To Site? Need Help?

All times are GMT. The time now is 11:27 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2