Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

JL 500 1 REV 10 power problem
JL 500 1 REV 10 power problem
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th May 2013, 08:07 PM   #1
dmarrow is offline dmarrow
diyAudio Member
 
Join Date: Mar 2013
Default JL 500 1 REV 10 power problem

I have a 500 1 rev 10 I have replaced all 8 output fets and the gate resistors. When I tried to power it up for the first time after the repair the power light came on for about 2 seconds and shut off
  Reply With Quote

Reply


JL 500 1 REV 10 power problemHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
JL Audio 500/1 Rev. 10 hifonics hugh Car Audio 39 13th August 2015 09:22 PM
JL Audio 500/1 Rev. 3 Two with same problem RJohns777 Car Audio 20 21st November 2011 04:08 AM
JL Audio 500/1 v1 Rev. 10 Board RiLoWa Car Audio 40 11th October 2011 03:19 AM
JL Audio 500/1 v1 Rev. 10 Boards #2 RiLoWa Car Audio 108 6th October 2011 04:18 AM
jl audio 1000/1 version 1 rev 10 klangston76 Car Audio 17 2nd October 2011 08:59 PM


New To Site? Need Help?

All times are GMT. The time now is 11:33 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki