Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 25th April 2013, 11:35 AM   #1
dhamia is offline dhamia  United Kingdom
diyAudio Member
 
Join Date: Jul 2010
Default Punch 60dsm

Ok this Punch 60dsm powers up but no sound
I have changed the 10uf caps on the pre-amp board
But still no sound

All the outputs look fine
There is no evidence of burnt traces or transistor damage
  Reply With Quote
Old 25th April 2013, 04:52 PM   #2
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
Check the other caps on the board such as anything related to turn on delay.

As long as you are sure you installed the caps correctly and there was no trace damage on the input board, that should be OK.

Also check to see if the amp is producing rail and regulated voltage.
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 27th April 2013, 12:16 AM   #3
dhamia is offline dhamia  United Kingdom
diyAudio Member
 
Join Date: Jul 2010
I switched the preamp board with one from a donor punch60 that was known to be working
There is still no sound.

Can you explain which section is the turn on delay circuit please?

Also does this amp have a prorection circuit that may have engaged?
  Reply With Quote
Old 27th April 2013, 05:20 PM   #4
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
Is the amp making rail and regulated voltage?
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 27th April 2013, 05:47 PM   #5
dhamia is offline dhamia  United Kingdom
diyAudio Member
 
Join Date: Jul 2010
How do I test the rail voltage and regulated voltage?
  Reply With Quote
Old 29th April 2013, 01:07 PM   #6
dhamia is offline dhamia  United Kingdom
diyAudio Member
 
Join Date: Jul 2010
Ok update,

it appears there were 3 broken traces on the main board where the pre amp board is soldered, I patched them up and it works fine.

Thanks Seankane for your suggestions.
  Reply With Quote
Old 29th April 2013, 06:41 PM   #7
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
No problem, glad you figured it out, sometimes the answer is staring you in the face.
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Punch 250M vs Punch 500M seankane Car Audio 29 23rd November 2012 09:21 PM
Looking for more punch Starstrider Subwoofers 2 27th September 2012 02:04 AM
Punch 200ix seankane Car Audio 6 5th October 2011 02:27 AM
Selling a punch 250a2, old punch 75, and ppi epx 205 on EBAY ppia600 Swap Meet 0 23rd February 2008 01:17 AM
My experience: the cheap punch set VS Greenlee punch vax9000 Tubes / Valves 5 21st July 2006 07:52 PM


New To Site? Need Help?

All times are GMT. The time now is 04:46 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2