Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 1st April 2013, 01:08 PM   #1
diyAudio Member
 
Join Date: Jan 2013
Default Help with repair of kac-x621

I have a kenwood kac-x621 that had 2 of the power supply fets blow on it so I replaced all 8.

When I power it on the LED blinks and I get LCD screen but something isn't right still -- after the mute delay and the amp kicks on there is 25 amp or so current draw -- I quickly shut it down.

It seems the fets even when clamped t the heatsink get warm really fast so I am using current limiter now.

I cannot seem to find out what is drawing the extra current. I checked the driver transistors "Q119" and "O120". Took them out of the circuit and found they are at Hfe of 141 and both test fine in diode check.

No shorts on any of the output transistors.

I read Perry Babins amp primer and purchased a cd... I think the protect maybe coming on for a good reason... perhaps the failure in the power supply took something out with it... any ideas on how to isolate it?

Thanks for your help!

MFA
  Reply With Quote
Old 1st April 2013, 02:36 PM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Check your email.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kenwood kac 820 repair jol50 Car Audio 26 23rd August 2010 03:21 AM
Kenwood KAC-X301T and KAC-X201T:Do they share the same board? spooney Car Audio 1 25th October 2007 01:08 AM
Kac-7201 sphinxxx Car Audio 3 4th April 2007 07:14 PM
Kac-929 sphinxxx Car Audio 3 2nd April 2007 11:46 PM
looking for repair schematics for a Kenwood KAC-Q74 jude Solid State 0 1st August 2002 07:59 PM


New To Site? Need Help?

All times are GMT. The time now is 03:13 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2