jl audio 500/1 power supply wont turn on - Page 3 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 17th March 2013, 02:47 PM   #21
diyAudio Member
 
jeanious2011's Avatar
 
Join Date: Nov 2010
Location: Texas
I'm going to have to start a thread, but i recently replaced all the blown b+ caps (25v 2200uf with nichicon "he" 25v 4700uf) all the ps fets with irfz44n and the rectifier with a mur1620g. I gave it power and nothing...no current draw, no light, no rail voltage....i took the voltage for the 10 pin connector and compared them to Perry's, mine are off. Ilk start a post here in a sec.
  Reply With Quote
Old 19th March 2013, 07:15 AM   #22
diyAudio Member
 
Join Date: Feb 2008
Send a message via AIM to MatthewS Send a message via MSN to MatthewS Send a message via Yahoo to MatthewS
Quote:
Originally Posted by kds9591 View Post
I believe the first JL Audio 500/1 I used the IRF540N in was around 2005 and while I have used the IRF540's as well I found that the IRF540N's were more consistently available from several sources and cost slightly less so I always had them on hand. Perry mentioned IRF540N's don't work in Rockford amps and I vaguely remember repairing a Rockford amp a few years back trying to use the IRF540N's and had trouble with them and switched them out with IRF540's.

With the JL Audio 500/1 amps I always replaced all 4 outputs with the IRF540n's with the same lot number even if 2 of them tested good. I usually use up all MOSFETS with the same lot number before using ones with a new lot number but over time you still get a collection of same number MOSFETS with different lot numbers. With those I use my transistor/MOSFET tester to match the Hfe (gain) and write the gain # on the back of the tab with a fine point Sharpie. I repaired a JL Audio 500/1 for a friend a couple of years ago and replaced the 4 outputs using IRF540N's from 2 different lot #s but gain matched and after 2 years there have been no issues with the amp.

Whether or not a IRF540N works or not depends on how critical the design of the circuit its used in. Better designs are less critical and have a wider tolerance. There are a few differences between the spec sheets of the IRF540 and IRF540N but nothing substantial so in most circuits they should be interchangeable. But as in most things YMMV.
Appreciate you explaining all that, but we pretty much think alike on all of it. Agree, agree, and agree some more. I just haven't had that luck with the JL slash amps. I've only had about half a dozen ever come in, but none had a 540n in them, rev3 or rev10 500/1's. None of them were worked on either. Weird...
  Reply With Quote
Old 19th March 2013, 10:25 AM   #23
kds9591 is offline kds9591  United States
diyAudio Member
 
Join Date: Apr 2008
Location: Bensalem, PA
The IRF540N's I use are made by International Rectifier although I think Fairchild makes the "N" suffix too. I keep some IRF540's in stock as well but find them a little harder to get and they consistantly cost more. The cost difference adds up fast when you have a lot of MOSFETS to change in the bigger amps so I found myself always ordering the "N" suffix over the years. Yet the "N" suffix has a higher rated Drain current 33A vs 28A but costs less. Go figure.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Jl Audio 500/5 won't turn on at all. jeanious2011 Car Audio 17 21st February 2013 06:42 PM
jl 500\1 power supply doesnt turn on trevor420420 Car Audio 6 23rd December 2011 11:58 PM
JL Audio 500/1 Plastic Seperator for Power Terminal RiLoWa Car Audio 0 17th April 2011 07:35 PM
DPS-500 Innovative Power supply for Audio AP2 Class D 17 19th November 2010 01:37 PM
wont turn on 2, linear power 4753 iq. IMPALAMAN1 Car Audio 7 4th November 2005 06:12 AM


New To Site? Need Help?

All times are GMT. The time now is 06:17 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2