rockford fosgate t20001bd - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 22nd February 2013, 09:28 PM   #1
diyAudio Member
 
Join Date: Nov 2008
Default rockford fosgate t20001bd

Hi I need some help with part#'s D402 and T400 I need to order some! THANKS!!
  Reply With Quote
Old 22nd February 2013, 09:38 PM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
The diode is probably a EGF1D.

You can likely get the transformer from Rockford.
  Reply With Quote
Old 22nd February 2013, 09:42 PM   #3
diyAudio Member
 
Join Date: Nov 2008
Hi Perry the diode is marked ED54a THANKS!
  Reply With Quote
Old 22nd February 2013, 09:49 PM   #4
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
http://datasheet.octopart.com/EGF1D/...t-11554395.pdf

ED is the mark. The rest is probably a production code.
  Reply With Quote
Old 22nd February 2013, 09:54 PM   #5
diyAudio Member
 
Join Date: Nov 2008
THANK YOU!!
  Reply With Quote
Old 8th March 2013, 01:23 AM   #6
diyAudio Member
 
Join Date: Nov 2008
Is there a resistor I can remove to disconnect the preamp section from the power amp section on this amp?
  Reply With Quote
Old 8th March 2013, 02:26 AM   #7
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
R300 should do it but I don't know if it will be stable with it removed.

Why do you want to break the connection between the two sections?
  Reply With Quote
Old 8th March 2013, 03:33 AM   #8
diyAudio Member
 
Join Date: Nov 2008
HI perry! it is drawing current and going in to protect all transistors test good and one of the transformers is wining!
  Reply With Quote
Old 8th March 2013, 03:45 AM   #9
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
How much current is it drawing?

Is there excessive DC on the speaker terminals?

Are any of the FETs getting hot?
  Reply With Quote
Old 8th March 2013, 03:53 AM   #10
diyAudio Member
 
Join Date: Nov 2008
Its drawing 25 amps. no dc on speaker terminals. I have not left it on long enough to see if the fets are getting hot.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rockford Fosgate T20001BD wont power up amp it up Car Audio 10 23rd January 2013 04:26 PM
Rockford Fosgate T20001BD brandes.cm Car Audio 9 3rd August 2012 05:30 AM
Rockford Fosgate T20001bd Triden312 Class D 3 22nd November 2009 10:54 PM
Rockford Fosgate - T20001bd dtek Car Audio 5 23rd October 2009 01:43 AM
Rockford T20001bd PQatPIT Car Audio 4 11th January 2009 06:59 PM


New To Site? Need Help?

All times are GMT. The time now is 09:40 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2