hifonics bxi2010d in protection mode - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 4th February 2013, 12:55 PM   #1
ivkata is offline ivkata  United States
diyAudio Member
 
Join Date: Dec 2010
Arrow hifonics bxi2010d in protection mode

i got 2 of those hifonics bxi2010d with the same issue :
-once conected to power source the green light illuminates for a sec and then goes to red-protection.

both units came form the same vehicle ,same issue ,both boards look mint with no visible damage.I cannot find blown fets in either power or output section ,please advise
  Reply With Quote
Old 4th February 2013, 05:54 PM   #2
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
There are 2 transistors on the audio driver board marked 1D. They are probably bad and causing the protect.

Post a photo of the board, so I can see what configuration of board it is.
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 5th February 2013, 01:54 AM   #3
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
These.
Attached Images
File Type: jpg bxi2006daudiodriverboard01b2x.jpg (108.4 KB, 51 views)
  Reply With Quote
Old 5th February 2013, 12:41 PM   #4
ivkata is offline ivkata  United States
diyAudio Member
 
Join Date: Dec 2010
how do i decode what's the part number on those transistors so i can by few and swap them out ?
  Reply With Quote
Old 5th February 2013, 01:45 PM   #5
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
The SMD Code Book

MMBTA42
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hifonics Brutus BXI1610 Amp in Protect mode cwelty Car Audio 13 30th October 2012 09:46 PM
hifonics bxi2010d DREW028 Car Audio 32 15th April 2012 01:31 AM
Amp Protection Mode sseabrook07 Car Audio 3 29th October 2006 02:26 PM
Protection circuit on Hifonics Atlantis 69CamaroSS396 Car Audio 8 6th August 2006 01:18 AM
protection mode won't go off Darkcrusher Solid State 5 2nd February 2006 02:10 PM


New To Site? Need Help?

All times are GMT. The time now is 10:03 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2