Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd February 2013, 09:08 PM   #21
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
It was causing too much voltage to be developed across the bias network.
  Reply With Quote
Old 2nd February 2013, 09:49 PM   #22
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
OK makes sense.

Parts for the 650 will be in Monday. Talk to you about that mess then...lol.
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Old school Rockford Fosgate Power 1000c MOSFET Prime mova Car Audio 31 6th June 2013 08:16 AM
Rockford Fosgate Power 1000 MOSFET Amplifier Prime mova Car Audio 0 14th December 2012 10:50 AM
rockford fosgate power 650 mosfet mike49504 Car Audio 43 24th March 2011 10:21 PM
rockford fosgate power 300 mosfet mike49504 Car Audio 26 23rd December 2009 04:06 AM


New To Site? Need Help?

All times are GMT. The time now is 03:07 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2