Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 19th January 2013, 05:01 PM   #1
diyAudio Member
 
Join Date: Jun 2012
Default Autotek XS1600X

This amp is using RFP70N06'S with 27 ohm gate resistors..

The drivers for the power supply are C2316 and A916 will the BD139 and BD140's work for the drivers??
  Reply With Quote
Old 19th January 2013, 05:06 PM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
There shouldn't be a problem using the BD139/140 as drivers in the power supply.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
AutoTek SX5750 Diag JRR81 Class D 0 3rd December 2012 04:32 PM
autotek xs1500.1 DREW028 Car Audio 17 14th March 2012 01:00 AM
autotek 7050xx specs!!!help!! metso Car Audio 2 9th July 2007 05:58 AM
Autotek 7600bts electropro Car Audio 2 28th January 2007 03:03 AM
autotek MM1000.1D xtremesound Class D 0 22nd February 2006 11:52 PM


New To Site? Need Help?

All times are GMT. The time now is 02:21 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2