Rockford Fosgate P1000 Amp Wont Power On? - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 13th January 2013, 09:26 PM   #1
diyAudio Member
 
Join Date: Jan 2013
Default Rockford Fosgate P1000 Amp Wont Power On?

Hi Guys,

i have just transferred my stereo from my old car to my new one and im just having trouble getting my rockford p1000 amp to turn on. Things i have done so far is: Ran 2 gauge wiring from the battery to the amp (located in the boot) and grounded the amplifier with a fresh earth that i drilled myself. I have tested the connections with multimeters and know that my earth and power are all fine, now heres where i need your help.

The car i bought came with a remote wire and rca's already ran through the car from the previous owner but i CANT check the remote wires connection(i dont know if they are connected at all just ran through the carpet) to the headdeck since i didnt want to tear apart my new cars dash (for a chance of breaking plastics), i just connected them to the amp. My mate told me that rockford amps will not power on unless they have the remote wire connected? So can anyone please try and shed some light as this amp has been working perfectly.

Cheers
  Reply With Quote
Old 13th January 2013, 09:43 PM   #2
diyAudio Member
 
Deadly Sones's Avatar
 
Join Date: Feb 2011
Location: Windsor, Ontario
Turn on the deck and verify that you have 12v coming from the remote line. Red lead on remote wire, black on a ground. While you have it out you might wanna double check the supply power and ground connections too.

Last edited by Deadly Sones; 13th January 2013 at 10:02 PM.
  Reply With Quote
Old 13th January 2013, 10:09 PM   #3
diyAudio Member
 
Join Date: Jan 2013
cheers for the tips! i didnt even think to check the remote hah it was such a big night last night feeding the power wire through carpet and wiring the sub up so hopefully your suggestion works.
  Reply With Quote
Old 13th January 2013, 10:23 PM   #4
diyAudio Member
 
Deadly Sones's Avatar
 
Join Date: Feb 2011
Location: Windsor, Ontario
well its not too often I can help on this forum... lol, but that's a good place to start.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help: Rockford fosgate 551s power amp or Kicker zx750.1 amp?? Acetac Car Audio 9 25th November 2012 10:45 PM
Rockford Fosgate punch p500-2 wont power on ivkata Car Audio 9 6th November 2012 04:15 AM
Rockford Fosgate Power 20001 bd amplifier power rating?? pachoorion Car Audio 8 8th May 2011 10:49 PM
Tips on fixing my Rockford P1000-1bd jamesnail Solid State 8 30th January 2010 09:56 PM


New To Site? Need Help?

All times are GMT. The time now is 03:04 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2