JL 500/1 - Page 2 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 14th January 2013, 08:07 PM   #11
2many is offline 2many  United States
diyAudio Member
 
Join Date: Jan 2013
Location: SEMO
been doing some searching on parts to use or to substitute.
so far I have:

270-47-RC possibly for the gate resistors please correct if not right
IRFZ44NPBF for the power fets

just not sure on the power drivers Q608/11
I found a post saying to use Transistor marked UY - KTC4379
Transistor marked WY - KTA1666
unless they are PNP drivers then to use 2SB1260

but I'm not 100% this is just based off of searching this forum.

q608/11 are marked wy720 but I'm not finding a substitute
  Reply With Quote
Old 15th January 2013, 12:33 AM   #12
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
What revision is the main board?
  Reply With Quote
Old 15th January 2013, 01:05 AM   #13
2many is offline 2many  United States
diyAudio Member
 
Join Date: Jan 2013
Location: SEMO
that would be rev 11
  Reply With Quote
Old 15th January 2013, 01:20 AM   #14
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
The 2SB1260 is sued in place of the WY transistors.

The resistors that you listed are OK.
  Reply With Quote
Old 9th February 2013, 08:12 PM   #15
2many is offline 2many  United States
diyAudio Member
 
Join Date: Jan 2013
Location: SEMO
finally got around to testing after installing the new components. started a new job so time has been limited.

Anyways, I powered it on with my power supply and 10a fuse. it will blow the fuse in about 20secs with only the green light illuminating. any idea where to look next? or should I increase the fuse, havent done this yet as I would rather not redo what I have already done.
  Reply With Quote
Old 9th February 2013, 09:42 PM   #16
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Are the FETs clamped to the sink or is the board still out of the heatsink?
  Reply With Quote
Old 10th February 2013, 01:32 AM   #17
2many is offline 2many  United States
diyAudio Member
 
Join Date: Jan 2013
Location: SEMO
all fets are clamped to the sink
  Reply With Quote
Old 10th February 2013, 02:39 AM   #18
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
If they're clamped, go to a 15 amp ATC or ATO fuse.

I'm assuming that you didn't clamp them directly to the sink and you reinstalled the mica insulator behind them.
  Reply With Quote
Old 10th February 2013, 07:42 PM   #19
2many is offline 2many  United States
diyAudio Member
 
Join Date: Jan 2013
Location: SEMO
well I had gone out and gotten some 15a fuses but turns out my power source died. and yes perry, I reapplied thermal paste(after cleaning) to the insulator and the heatsink as it was prior to repair. I read on here that removing that was not recommended.

going to see if I can borrow a battery. as of now I have the fets clamped to the heatsink but is not in the case, so taking it out to my car isnt feasible at this time.
  Reply With Quote
Old 10th February 2013, 10:39 PM   #20
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Be very careful with the battery. If you install it in your car for testing, you still need the 15 amp fuse.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
JL AUDIO 500.1 mike49504 Car Audio 5 15th April 2012 05:48 AM
JL Audio 500/5 help please! Black Frog Car Audio 24 13th March 2012 07:33 AM
JL Audio 500/1 mike49504 Car Audio 55 23rd September 2011 05:26 AM
JL Audio 500/1 mike49504 Car Audio 1 15th August 2010 09:02 PM
FS: JL 500/1 ($500 CAD located in GVA) Dynamix Lude Swap Meet 0 27th October 2004 03:21 AM


New To Site? Need Help?

All times are GMT. The time now is 10:49 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2