Soundstream Rubicon 604 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 28th December 2012, 09:07 PM   #1
diyAudio Member
 
Join Date: Jun 2012
Default Soundstream Rubicon 604

Amp powers up and produces both + - rail voltages also produces both + - 15 volts on all op-amps..

Amp has no sound and all 4 of the clip lights are solid red all of the time..

Any ideas??
  Reply With Quote
Old 29th December 2012, 12:35 AM   #2
diyAudio Member
 
Join Date: Dec 2005
Location: Northern California
The clip leds are shunted/switched by a MPS8599 transistor that gets it signal from the FEB modules. The transistor shunts across the led and it base is driven from one of the FEB's outputs. Check Q101, Q102, Q122, and Q123 for proper operation.
The rails should be as below:
P. S. RAILS: HV: +/- 29.5V
HC: +/- 23V
RB: +/- 18V

Hope some of this info is helpful...
  Reply With Quote
Old 29th December 2012, 01:44 AM   #3
diyAudio Member
 
Join Date: Jun 2012
Q101, 102, 122, 123 all have the same voltages on them

They test fine out of the board heres the voltages i get


Emitter:29.22
Base:28.54
Collector:29.22

Clip lights went off but amp still has no output
  Reply With Quote
Old 29th December 2012, 02:16 AM   #4
diyAudio Member
 
Join Date: Jun 2012
Ok if i plug the Rca jacks into channels 3 and 4 i get sound from all channels..

If i plug the rca's into channels 1 and 2 i get no sound..

Any ideas?
  Reply With Quote
Old 29th December 2012, 02:51 AM   #5
diyAudio Member
 
jeanious2011's Avatar
 
Join Date: Nov 2010
Location: Texas
Rca input switch, rca solder broken?
  Reply With Quote
Old 29th December 2012, 04:54 AM   #6
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Are you sure that you don't have that backwards? The amp can feed all 4 channels with input from channels 1 and 2 but not by feeding 3 and 4 (unless I'm misreading the manual).

http://www.soundstream.com/manuals/A...b204404604.pdf
  Reply With Quote
Old 29th December 2012, 05:29 AM   #7
diyAudio Member
 
Join Date: Jun 2012
Ok yeah channels 1 and 2 feed all 4 channels..

If i plug the rca jacks in channels 3 and 4 i get no sound..

The Rca Jacks for the RCA outputs are broken ..

Anyone know where i can buy a new set of Jacks or does anyone have some laying around i can buy ??
  Reply With Quote
Old 29th December 2012, 05:39 AM   #8
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
There is a switch on the bottom of the amp that allows you to feed all channels individually. It's shown in the manual.

I don't have a source for the jacks. How are they broken?
  Reply With Quote
Old 29th December 2012, 05:41 AM   #9
diyAudio Member
 
Join Date: Jun 2012
The part where u plug the rca jack into is snapped off
  Reply With Quote
Old 29th December 2012, 05:51 AM   #10
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
It won't be a perfect match but if you have no other options, maybe something like THIS will work.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Soundstream Rubicon 604 not powering on azvrt Car Audio 6 9th February 2012 05:01 PM
Soundstream Rubicon 604 not playing nicely... frekiy Car Audio 11 23rd January 2012 10:31 AM
Soundstream Rubicon 1002 mike49504 Car Audio 6 30th November 2010 03:41 PM
Soundstream Rubicon 302 mike49504 Car Audio 20 6th June 2010 02:09 AM
Soundstream Rubicon 805 audiobahnkid592 Car Audio 16 23rd July 2008 10:13 PM


New To Site? Need Help?

All times are GMT. The time now is 07:09 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2