Alpine MRV-1507 - Page 4 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 3rd January 2013, 07:24 AM   #31
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Are you measuring across the speaker terminals?

Post a photo of the components in the channel with DC.
  Reply With Quote
Old 3rd January 2013, 07:50 AM   #32
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
Yes across the speaker terminals.

This is a photo of the half of the output board that is giving me trouble.
Attached Images
File Type: jpg HPIM3327[1].jpg (1,008.7 KB, 32 views)
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 3rd January 2013, 08:17 AM   #33
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Connect a dummy load across the speaker terminals. Does that stop the DC and allow the amp to power up or does the amp draw excessive current?
  Reply With Quote
Old 3rd January 2013, 08:22 AM   #34
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
Connecting a 4 ohm dummy load allows the amp to power up and be stable with solid green light but the red protection light is flashing.

The pulsing DC is gone as well.
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 3rd January 2013, 08:25 AM   #35
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Did you find any outputs that were shorted or leaky?
  Reply With Quote
Old 3rd January 2013, 08:34 AM   #36
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
I have not tested them yet, why does the dummy load remove the DC and allow the amp to power?

Is the red protection light flashing because the outputs are removed?
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 3rd January 2013, 08:40 AM   #37
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
The DC source causing the DC on the speaker terminals without the outputs likely has significant resistance. If not, it would cause the amp to draw excessive current.

The red LED blinking may be a separate problem.
  Reply With Quote
Old 3rd January 2013, 08:45 AM   #38
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
2 outputs were shorted and 2 were leaking from that channel.

Could a defective driver be causing the DC source?

Why does the dummy load get rid of the DC and allow the amp to power?
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 3rd January 2013, 08:54 AM   #39
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
Q419 a C2682 has full rail on every leg.

Q420 a C2682 does not from the other channel.

In the picture they are the 2 components that are screwed down to the heat sink still where the fets clamp down.

Just poking around and thought I would mention it??
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 3rd January 2013, 09:02 AM   #40
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
You can't rely on DC voltage with the outputs out of the channel.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alpine MRV 1507 Tom7227 Car Audio 1 15th June 2012 06:02 PM
Alpine MRV-1507 mike49504 Car Audio 2 2nd February 2012 07:43 AM
Alpine MRV-1507 canadianeh Car Audio 9 6th April 2011 02:16 AM
Alpine MRV-1507 Dr Zeus Car Audio 15 3rd March 2011 12:17 AM
Alpine MRV 1507 FSUSeminole Car Audio 8 1st January 2011 08:04 PM


New To Site? Need Help?

All times are GMT. The time now is 02:58 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2