P50N06 ? - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 10th December 2012, 08:27 PM   #1
diyAudio Member
 
Join Date: Nov 2012
Default P50N06 ?

I was wondering wondering if someone would know what a good replacement transistor would be at radio shack for a P50N06 transistor ?
  Reply With Quote
Old 10th December 2012, 11:27 PM   #2
diyAudio Member
 
Join Date: Nov 2012
The only thing i can find even close to this match would be NTE2940 - MOSFET-Power N-Channel High-Speed Switch 60V

NTE2940 - MOSFET-Power N-Channel High-Speed Switch 60V : High-Speed Switches | RadioShack.com
  Reply With Quote
Old 11th December 2012, 12:38 AM   #3
rickcl is offline rickcl  United States
diyAudio Member
 
Join Date: Mar 2003
Location: California
Default Take a look here

http://octopart.com/partsearch#searc...ta&q=P50N06%20
  Reply With Quote
Old 11th December 2012, 12:41 AM   #4
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
Nothing that would be at radio shack, they dont have much for tansistors. I would just order them and replace them. You can easily find them, or just upgrade to IRF3205, and change the gate resistors to 47 ohm.

Watcha workin on?
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 11th December 2012, 12:52 AM   #5
diyAudio Member
 
Join Date: Nov 2012
Do you think P50N06 St to 220 Transistor MOSFET N Channel 60V | eBay these would work apposed to my ST W540 Malaysia P50N06? Well im trying to figure out this Urban amp im working on im having a few problems i tried a 2 - K1420 replacement transistors in the amp and the led lit up for 1 sec and i heard something fry so i removed the transistors only to find out 1 was fried also im unsure about the output transistors also im unsure about what was originally in the amp cause i cant find a schematic i just assumed the it was just missing the 1 P050n06 cause thats what was right next to it also the output transistor have no part numbers on the transistors so i can not check the data sheet the whole amp only has a total 12 transistors im assuming 2 are for the power regulator the other 2 are for the power driver and the other 8 are for the output
  Reply With Quote
Old 11th December 2012, 01:48 AM   #6
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Never use NTE transistors in car amps. Don't buy semiconductors from ebay unless you know for a fact that the seller is reliable. There are too many counterfeit/second rate semiconductors being sold there.

What do you mean by 'power regulator' and 'power driver'?
  Reply With Quote
Old 11th December 2012, 02:05 AM   #7
diyAudio Member
 
Join Date: Nov 2012
Hi Perry
How r u? Well one of the transistor in the power supply is missing the transistor that was next to the missing slot was the ST W540 Malaysia P50N05 So with it being inline with the empty slot in the board im guessing it would be the same transistor on the other side of the power supply i have a transistor that is >-< current flow for the transistor and right next to that one the symbol on the transistor shows <-> im not the greatest when it comes to the power supply transistor im better with the Output Transistors im trying to learn just like the Output transistors if theres 4 transistors there 2 that are N Channel and 2 transistors that are P Channel im assuming i know i shouldnt be doing that but im guessing the symboled transistors <-> >-< would be the Voltage regulator transistors and the transistor im looking for is the power driver for the bi polar transistors correct me if im wrong
  Reply With Quote
Old 11th December 2012, 02:09 AM   #8
diyAudio Member
 
Join Date: Nov 2012
I tried replacing the ST W540 Malaysia P50N05 transistor with a k1420 and i placed one in the empty slot just some transistors laying around i had was in the same location as the transistor setup on this board so i thought i would try them fused and 12volt 1a power supply and even with that it didnt blow the fuse it took out of k1420 transistors within a second so im assumming my current matching was way off
  Reply With Quote
Old 11th December 2012, 02:14 AM   #9
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Post a photo of the board.

What are the part numbers on the output transistors.

<-> and >-< aren't transistors, they're rectifiers. This is covered on the basic amp repair page. Please read it, even the parts that you feel are irrelevant.

By 'power driver' do you mean power supply FET driver transistors? I don't know if you're too lazy to type it out (like r and u) or simply don't know what they're called.
  Reply With Quote
Old 11th December 2012, 02:29 AM   #10
diyAudio Member
 
Join Date: Nov 2012
The Output Transistors dont have any numbers on them its the first transistor ive come acrossed without numbers on them im sure i could get a picture for you. So i was wrong about the <-> >-< sorry i told you im not familiar with the power supply transistors and Rectifiers although from what i have seen in small amps theres usually only 2 1 of each in the power supply area of the circuit board and 2 'power driver' power supply FET driver transistors that operate the small Bi-polar transistors through out the circuit board im trying to learn alright sorry if im not explainning everything right im know some and i am awesome when it comes to soldering
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Replacement for a P50N06? spooney Car Audio 1 21st November 2007 04:17 AM


New To Site? Need Help?

All times are GMT. The time now is 11:34 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2