MTX Thunder AMP - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 7th December 2012, 02:12 AM   #1
diyAudio Member
 
Join Date: Nov 2012
Exclamation MTX Thunder AMP

Hi guys back for some more repairs I was wondering if anyone else has had issues with there MTX Thunder 2150 Amp It was repaired by MTX years ago they swapped out the board and replaced it with a new one well i didnt pay for it nor operate this amp it was given to me with issues :-( my issue is when your powering subs the amp light will flicker at a certain extent and of course cut out you can disconnect the RCA's the Subs will have variable current passing through the coils causing the speaker to move in and out without even music playing has anyone one else had this issue i checked all the chips they all seem to be good and also checked the RCA Ground shield.
  Reply With Quote
Old 7th December 2012, 02:15 AM   #2
diyAudio Member
 
Join Date: Nov 2012
I also have a 2300 with the same issue also installed with this amp and it has the same exact problem i dunno if that helps i dunno if the vehicle it came out of was lacking a good ground or what i do know the previous owner liked to turn all the inputs way up after warning him many of times.
  Reply With Quote
Old 7th December 2012, 05:43 AM   #3
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
Have you tried running both amps off of a different head unit to confirm the head unit is not the problem?
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 7th December 2012, 05:57 AM   #4
diyAudio Member
 
Join Date: Nov 2012
Thats a no go ive tried ipod my laptop and even a known dvd player i use in my car with my other system im testing it in the house with my optima car battery yellow top still no luck i think it has something to do with the interns i read something about ground shield in a post but that doesnt seem to be the case i resolder all that still no luck even added more solder to the ground terminal like i seen in a post i dont understand it i know the bias hasnt been changed because im the one that pulled the factory spec sticker on the back like i said above this amp i know was sent to MTX and the board was swapped out both of them actually and the person who had the amps i know didnt open them up hes not mechanical inclined when it comes to electronics he would ask me every or look at the amps so i dunno good guess tho thanks for the advice also the same rca wire and laptop i use for all my stereo repairs so i know thats not a issue however i tried the ipod dvd player so i dunno would be nice to get them fixxed i hear these amps are a bear cat to work on tho so i dunno i thought i was on a roll ive fixxed three amps laying around my house that werent working thanks for your help tho hopefully someone will beable to tell me something from past XP
  Reply With Quote
Old 7th December 2012, 06:00 AM   #5
diyAudio Member
 
Join Date: Nov 2012
three car amps fixxed this week and im working on a house reciever that would turn on past protect just missing the center channel till i can finish testing that one this weekend
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MTX Thunder 1501d Amp Repair (~2004 Model) ---Turns on (Red LED lit) but no sound thevanman316 Car Audio 10 24th November 2012 05:38 AM
MTX Thunder X1000D mike49504 Car Audio 2 26th April 2012 02:02 AM
MTX Thunder Elite 1501d amp problems, could be fried? Infinity2600 Car Audio 13 11th October 2011 05:16 PM
MTX Thunder 7804 Dr Zeus Car Audio 16 9th February 2011 08:41 PM
MTX Thunder 3401 Class D Mono Amp gssmind Swap Meet 11 6th October 2006 10:32 AM


New To Site? Need Help?

All times are GMT. The time now is 04:55 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2