Hifonics XX-Cyclops - Page 2 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 4th December 2012, 10:41 AM   #11
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
Its a DC spike.
__________________
BK 1544 40Mhz scope.....Pyramid PS-26KX supply.....Tenma 72-380 Func. Generator
  Reply With Quote
Old 4th December 2012, 06:00 PM   #12
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
If you have DC, that's why the relays aren't engaging. The problem is likely on the driver board but you should confirm that all regulators are producing the correct output voltage and that those voltages are reaching the driver board pins.
  Reply With Quote
Old 5th December 2012, 02:41 AM   #13
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
Sometimes the relay pulses on then off.

I don't see the -15VDC on any pins of the driver card. The regulator is working, just nothing ohms out to the module.

The ext2000D schematic doesn't map the module pins correctly.
__________________
BK 1544 40Mhz scope.....Pyramid PS-26KX supply.....Tenma 72-380 Func. Generator
  Reply With Quote
Old 5th December 2012, 03:19 AM   #14
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
No -15v. See attached.
Attached Images
File Type: jpg 4070pinout01.jpg (153.2 KB, 86 views)
  Reply With Quote
Old 31st March 2013, 05:23 PM   #15
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
Voltages seem fine with the driver card removed. The two fets that tie to U5 pin 12 seem to fail constantly. I get no oscillation on the gates of any output fets.
__________________
BK 1544 40Mhz scope.....Pyramid PS-26KX supply.....Tenma 72-380 Func. Generator
  Reply With Quote
Old 31st March 2013, 08:09 PM   #16
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Are the FETs failing before the amp ever produces oscillation?
  Reply With Quote
Old 31st March 2013, 08:15 PM   #17
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
Correct, I see no oscillation and the fet(s) fail.
__________________
BK 1544 40Mhz scope.....Pyramid PS-26KX supply.....Tenma 72-380 Func. Generator
  Reply With Quote
Old 31st March 2013, 08:35 PM   #18
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
That would tend to indicate that there is an open circuit between that pin and the FETs that's letting the gate voltage float. The connection could be intermittent.
  Reply With Quote
Old 31st March 2013, 10:07 PM   #19
diyAudio Member
 
Join Date: Sep 2009
Location: Wisconsin
All gates are driven to the negative rail with no oscillation. I should note those fets fail when I have the protection circuit removed, D206. Otherwise the amp will go straight into protect.
__________________
BK 1544 40Mhz scope.....Pyramid PS-26KX supply.....Tenma 72-380 Func. Generator
  Reply With Quote
Old 1st April 2013, 03:35 PM   #20
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
If you remove all of the FETs driven by U5, does the amp power up and produce audio?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need output driver card info for Hifonics Cyclops Deadly Sones Car Audio 2 19th October 2011 11:29 PM
Hifonics XX Chaos mike49504 Car Audio 1 3rd September 2011 06:08 AM
Hifonics XX Chaos mike49504 Car Audio 35 23rd July 2011 07:06 AM
hifonics hurcules xx mike49504 Car Audio 8 2nd February 2009 12:56 AM
hifonics colossus xx mike49504 Car Audio 7 29th November 2008 12:15 AM


New To Site? Need Help?

All times are GMT. The time now is 03:43 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2