2 Jl 500/1 amps one for parts one for repair - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 4th November 2012, 01:20 AM   #1
diyAudio Member
 
Join Date: Nov 2012
Location: Lansing
Default 2 Jl 500/1 amps one for parts one for repair

I'm kinda new to repairing amps but I can follow instructions really good, haha but really I am kinda up to speed with automotive electronics, but I do need help.
Here's the thing I just acquired two non working 500/1 JL audio amps One amp has an Ohm's light that seems to stay on indefinately and the other turns on fine but doesn't seem to produce anything more than a barely audible 10 decibels from my sub (which is a brand new 15in JL W0V3 SVC 4Ohm) both amps worked in different cars less than a year ago and are in good physical shape so I'd like to fix both if possible or at least get on good working amp outta this.
  Reply With Quote
Old 4th November 2012, 01:42 AM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
The one with the low impedance LED lit may have shorted output transistors.

With the black probe on the amp's ground terminal, what is the DC voltage on the positive and negative speaker terminals?
  Reply With Quote
Old 4th November 2012, 03:10 AM   #3
diyAudio Member
 
Join Date: Nov 2012
Location: Lansing
ill have to go borrow a multimeter tomorrow since my doesnt seem to be in my toolbox and get back to you on that. I also at some point and time have to go pick up the amp with the Low OHM light on. The amp I'm more concerned about is the one that seems to power on fine but doesn't produce any real volume...no matter what amp settings, speaker config, or head unit???
  Reply With Quote
Old 4th November 2012, 07:16 PM   #4
diyAudio Member
 
Join Date: Nov 2012
Location: Lansing
Another question will a rev 10 work in place of a rev 3?
  Reply With Quote
Old 4th November 2012, 07:25 PM   #5
diyAudio Member
 
Join Date: Nov 2012
Location: Lansing
and also do I need power to the amp to check out dc voltage on my speaker terminals?
  Reply With Quote
Old 4th November 2012, 10:25 PM   #6
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
For this thread, pick one amp and describe which one you choose in your next post in this thread. For the other amp, start another thread, listing the problems/symptoms for it.

Yes. The amp must be powered up normally when measuring the voltage on the speaker terminals.
  Reply With Quote
Old 4th November 2012, 10:29 PM   #7
diyAudio Member
 
Join Date: Nov 2012
Location: Lansing
ok perry Were gonna stick with the low ohm light for this thread.
  Reply With Quote
Old 4th November 2012, 10:49 PM   #8
diyAudio Member
 
Join Date: Nov 2012
Location: Lansing
I tested the speaker terminals to ground and found 76.4v on both positive and negitive from my understanding they should read around 40ish??? does that sound right and whats my next diagnoseing step?
  Reply With Quote
Old 4th November 2012, 10:51 PM   #9
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Are you sure that you checked one positive and one negative? It's strange that both are positive and that both are the same.
  Reply With Quote
Old 4th November 2012, 10:57 PM   #10
diyAudio Member
 
Join Date: Nov 2012
Location: Lansing
yes I checked both it is dark outside and Its possible I missed the negitive, I'll go try this one more time
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
JL Audio 500/5 repair advice, please wjyoung Car Audio 11 28th September 2011 11:42 AM
JL Audio 500/1 repair info Bertje Car Audio 11 30th October 2009 12:52 PM
JL Audio 500/1 Amplifier Repair Help Audioguy564 Car Audio 10 27th August 2009 02:24 AM
For Sale: Lot of 6 American-made car amps for parts/repair SixFoFalcon Swap Meet 0 22nd April 2009 07:54 PM
FS: JL 500/1 ($500 CAD located in GVA) Dynamix Lude Swap Meet 0 27th October 2004 03:21 AM


New To Site? Need Help?

All times are GMT. The time now is 01:44 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2