Equivalent Transistors for JL 500/1 - Page 4 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 15th November 2012, 02:23 PM   #31
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Testing as was suggested (without rail voltage) will tell you if the drive circuit is OK.

It's VERY odd that you have only 1 of the two paired FETs getting hot if the drive circuit is good. Either install two new FETs or move 504 and 505 to 506 and 507. Does the FET in the same location get hot?

It's also possible that one of the inductors is shorted. Do you see any signs of overheating on the output filter inductor?
  Reply With Quote
Old 15th November 2012, 11:29 PM   #32
diyAudio Member
 
Join Date: Jun 2012
Location: Huntsville, Alabama
Thanks Perry, I will go back in and perform the test again without the rail voltage (only applying remote power for a second or two and then scoping the gates of the output drivers). I will also move the transistors around and see if the problem follows the same transistor or just the location in the board. I will admit after last nights long battle with this amp, it feels like that point in a relationship where me and this amp may just need a few days apart, LOL. I have a couple more amps coming in for repairs and I will pick up a few more of these output transistors and the resistors when i order parts for the other amps so I can pull out the temporary pots.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
JL Audio 500/5 help please! Black Frog Car Audio 24 13th March 2012 07:33 AM
JL Audio 500/1 mike49504 Car Audio 59 27th January 2012 03:07 PM
JL Audio 500/1 mike49504 Car Audio 1 15th August 2010 09:02 PM
jl 500/1 SMD transistors shagone Car Audio 3 23rd June 2008 08:00 AM
FS: JL 500/1 ($500 CAD located in GVA) Dynamix Lude Swap Meet 0 27th October 2004 03:21 AM


New To Site? Need Help?

All times are GMT. The time now is 01:19 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2