Rockford Fosgate P500-2 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 22nd October 2012, 04:28 AM   #1
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
Default Rockford Fosgate P500-2

Hello I have a newer P500-2 that Rockford wont release the schematic to yet.

One channel has distortion, any idea where to look? Maybe the A/B driver card?

I posted a pic of the board, it is number 1325-52756-02 2007 model.

The wierd thing is the output on the scope with a 100Hz sine wave scope set at 2ms 20v/d the output looks clean.

When you play a music cd the amp plays ok for a little bit then as the volume is increased the amp cuts out with the red and yellow lights clipping on and off. When the volume is decreased then the channel gets distorted.

I dont understand why it is clean on the scope??????

Any ideas????
Attached Images
File Type: jpg P500-2 board pic 002.jpg (1,022.0 KB, 75 views)
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 22nd October 2012, 07:42 AM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
I haven't had to repair many of the amps of this type. The only fault that I found was as indicated in the attached image. The fault may be related if the transistor is leaky.

There can be different types of distortion. Not all are as easy to see as clipping or severe under-biasing.
Attached Images
File Type: jpg IMG_0186 - see note.jpg (227.4 KB, 69 views)
  Reply With Quote
Old 22nd October 2012, 08:43 AM   #3
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
I will check it out. It seems to only have distortion with a load. It looks clean on the scope.

There is no DC on either bridging terminal.
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 23rd October 2012, 01:33 AM   #4
diyAudio Member
 
Join Date: Oct 2010
As a side note, these daughercards appear to be used in a *bunch* of the newer style amps, I am pretty sure i've seen this same part number in the p300-1, p300-2,p400-2,p400-4 and p500-2, and I'm pretty sure even the power series t600-2/4 amps too...
  Reply With Quote
Old 4th December 2012, 09:21 PM   #5
404Amps is offline 404Amps  United States
diyAudio Member
 
404Amps's Avatar
 
Join Date: Oct 2010
Location: Metro Atlanta
@sean,

I'm having similar distortion on a p300-1 amp. what did you find to be defective on the 500-2?

@ PB,

What is the correct testing procedure for the smd transistor as noted below and in the attached photo?

Ps. I don't have a scope.
Click the image to open in full size.

Last edited by 404Amps; 4th December 2012 at 09:23 PM. Reason: to add notation
  Reply With Quote
Old 4th December 2012, 09:24 PM   #6
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
On that amp, the transistor was shorted. If you find a direct short between any of the legs of that transistor, it's defective. If it's leaking, you'd have to lift two legs or remove it for testing.
  Reply With Quote
Old 5th December 2012, 04:53 AM   #7
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
I never went any further on the amp, the customer is in no hurry and I have so many to repair I put it on hold. I will likely pick it up in the next few days, I am trying to get this tiresome punch 800.2 fixed its really wearing me thin!!
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
rockford fosgate t30001bd dips1982 Car Audio 17 27th December 2013 10:01 PM
Rockford P500-2 heatsink brandes.cm Car Audio 0 27th November 2011 02:08 AM
Rockford fosgate 4.6 X mike49504 Car Audio 14 28th May 2011 03:35 PM
Rockford Fosgate dtisme Car Audio 1 5th October 2010 11:39 PM
Rockford Fosgate 325.1 phreaktor Swap Meet 1 28th February 2008 11:54 PM


New To Site? Need Help?

All times are GMT. The time now is 08:18 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2