MTX RFL1200D no sound - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 18th October 2012, 03:33 PM   #1
diyAudio Member
 
Join Date: Jun 2002
Location: non
Default MTX RFL1200D no sound

I have one of these that produces no audio whatsoever. I am not finding anything shorted, none of the outputs are shorted.

However, the output filter gets red hot idling. And Q123 gets hot, and also has discolored the board. it does not appear to be shorted.

One half the output stage gates has a weird drive pulse, the other side appears to be pulled to negative rail.
  Reply With Quote
Old 18th October 2012, 04:49 PM   #2
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Post a photo of the board.
  Reply With Quote
Old 18th October 2012, 06:29 PM   #3
diyAudio Member
 
Join Date: Jun 2002
Location: non
I fixed it. one of the input op-amps was toast, and pinning the rail voltage to the amplifier.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MTX Thunder 1501d Amp Repair (~2004 Model) ---Turns on (Red LED lit) but no sound thevanman316 Car Audio 10 24th November 2012 05:38 AM
Kicker zx700.5 sub channel has humming sound and amp2 has echo like sound ivkata Car Audio 3 10th April 2012 09:23 PM
orion hcca250r, kicker zr 1000, mmats d800.2, mtx 6500d, mtx 942, rockford punch 45, ernie cosillos Swap Meet 3 12th February 2011 11:14 AM
Help me fix my MTX 1000D, no sound, just static hakentt Car Audio 13 30th October 2009 04:33 AM
Help me fix MTX 152 and MTX 500D hakentt Car Audio 94 8th December 2008 06:26 PM


New To Site? Need Help?

All times are GMT. The time now is 06:20 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2