Hifonics Brutus BX 2005d - Page 4 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 7th November 2012, 07:24 AM   #31
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
I don't know if both will work. I'd use whatever the originals were. If you want to know if both will work, try both and test thoroughly under heavy loads.
  Reply With Quote
Old 7th November 2012, 07:31 AM   #32
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
I replaced all the irf640N's and powered up the amp without the driver board installed, everything seems fine no dc voltage on the center legs of the 640's.

Does this mean likely Q7, Q11, Q19, Q22 are possibly leaky or shorted??

as replacements all I have on hand is MMBT3904 and 3906 and will those work for replacements since they are all the same pin configuration? I have a56 and a06 but I think the a06 is different pin configuration unless my old notes are wrong?
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch

Last edited by seankane; 7th November 2012 at 07:43 AM.
  Reply With Quote
Old 7th November 2012, 07:53 AM   #33
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
Looking at the data sheet I dont know if the others can handle the voltage the a42 and a92 are designed for???
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 7th November 2012, 08:32 AM   #34
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
I wouldn't try the 390xs. The MMBTA42/92 are very commonly used and it would be good to have them on hand.

The transistors open, short and leak. Sometimes, they have open junctions when tested on the board and after you remove them, they check OK (but they're not).
  Reply With Quote
Old 7th November 2012, 08:38 AM   #35
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
OK ordered 100 each from mouser have them Saturday maybe Monday for sure guess this amp is on hold till then!!!

Likely since the 640 do not have any voltage on the center leg eveything is ok on the main board?

Everything I have tested so far is within tolerance.
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 7th November 2012, 08:42 AM   #36
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
I can't say that everything is OK but it would appear that none of the outputs are leaky. They should read ~100k between legs 1 and 3 and you should read 2x the gate resistor value (10 ohms x2?) between the gate legs of the parallel transistors.
  Reply With Quote
Old 7th November 2012, 09:02 AM   #37
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
I do read 20 ohms between parallel outputs all the way across on both sides.

I read 24.80K ohms between legs 1 and 3 of every single output on the board.
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 7th November 2012, 09:35 AM   #38
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
24k is probably right if there are 4 parallel transistors. There is a 100k resistor on each transistor.
  Reply With Quote
Old 7th November 2012, 10:02 AM   #39
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
Yes each group has four fets. There are 4 9640's and 4 640's on each side of the amp with seperate power supplies but one pwm driver card running both supplies. I am asumming this is a dual mono block amp??
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 7th November 2012, 10:26 AM   #40
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
It has 2 groups of FETs that drive a single output.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hifonics Brutus BX1605D mike49504 Car Audio 3 25th July 2011 06:12 AM
hifonics brutus BXI1500D elev8rsh0es Class D 1 8th February 2011 05:47 PM
Hifonics Brutus lee1976 Car Audio 3 20th July 2010 12:19 PM
Hifonics BXi2006D Brutus! Formas Class D 0 30th August 2009 06:25 AM
hifonics brutus bxi1206d ray9043 Car Audio 2 30th March 2008 06:36 AM


New To Site? Need Help?

All times are GMT. The time now is 03:50 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2