Hifonics Brutus BX 2005d - Page 3 - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 30th October 2012, 08:04 PM   #21
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
I called maxxsonics today, and they dont stock the driver board nor do they sell internal parts for their amps.

I asked for a schematic and I got a maybe, I am suppose to call tomorrow and speak with a guy and tell him my "story".

Since its not a current model I did get a maybe. They said the last time they released one someone copied it and started building amps with it, they didnt say who or what but whatever.

So I called Mouser and ordered the 2SB1260's and they will be here this week.

I will keep you posted on the schematic results it would be way cool if they will give it to me. I am not looking to copy their amp and start building brutus amps but it would be nice to have for repairs and such.
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 30th October 2012, 09:53 PM   #22
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
If you get a diagram from them, that would be very surprising. It would be nice to see some of these manufacturers start to relax. They should realize that anyone who wants to copy a design can easily do it, with or without the schematic diagram.
  Reply With Quote
Old 31st October 2012, 01:27 AM   #23
diyAudio Member
 
Join Date: Oct 2012
Quote:
Quote:
Originally Posted by seankane View Post
I called maxxsonics today, and they dont stock the driver board nor do they sell internal parts for their amps.

I asked for a schematic and I got a maybe, I am suppose to call tomorrow and speak with a guy and tell him my "story".

Since its not a current model I did get a maybe. They said the last time they released one someone copied it and started building amps with it, they didnt say who or what but whatever.

So I called Mouser and ordered the 2SB1260's and they will be here this week.

I will keep you posted on the schematic results it would be way cool if they will give it to me. I am not looking to copy their amp and start building brutus amps but it would be nice to have for repairs and such.
Quote:
Originally Posted by Perry Babin View Post
If you get a diagram from them, that would be very surprising. It would be nice to see some of these manufacturers start to relax. They should realize that anyone who wants to copy a design can easily do it, with or without the schematic diagram.
Ohh... snap. hopeless for me to get a new driver board too then.
It's a bad support for customer. Because it's an old model and not current model still we can't have the schematics too. I guess maybe because they ask third party to manufacture their amps (OEM)?
  Reply With Quote
Old 2nd November 2012, 12:30 AM   #24
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Most of the amps are made by a handful of build houses. There are unique designs like those in Rockford, JL, newer Kicker and a few other amps. A lot of other amps use one of 2 or 3 designs that vary very little.
  Reply With Quote
Old 6th November 2012, 09:17 AM   #25
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
Few questions Perry

1: Installed new drivers on pwm board and re-installed board onto main board. Hooked up power and ground and remote. Blue LED came on and square wave on all gate pads......this is ok?

2: Installed all gate resistors and power supply fets, checked for bad connections by holding one probe at the end of the gate resistor and other probe on gate leg and all read near or 47 ohms and also checked for solder bridges but did not find any.....this is ok?

3: Removed shorted output fets and left the rest in the circuit....this is ok?

4: Not being that familiar with these amps is it ok to power up out of heat sink like I would a rockford amp??

5: Any special precautions I should take or anything else I should check before applying power?

Thank You
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 6th November 2012, 06:18 PM   #26
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
I powered up the amp all was well then poof went the outputs!!!

I can leave all the 9640's installed and it powers up fine, when I try installing the 640N's they blow instantly.

I have posted a pic of the audio driver board, you can see the drive transistors but I am not sure what is what.

There are 4 marked DK QR and 4 marked AG QR.
Attached Images
File Type: jpg Hifonics 2005D driver board 001.jpg (1,002.4 KB, 63 views)
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 6th November 2012, 11:10 PM   #27
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
#25:

1 and 2, yes.

3. Generally, yes but you have to make sure that none of the rest are leaking.

4. Yes if you monitor the temperature of the heatsink mounted components until you see if any are heating up.

5. Nothing that you normally wouldn't check.

The FETs should not have

#26:

DK = 2SC4672
AG = 2SA1797

Was the driver board in the amp when the FETs failed?
  Reply With Quote
Old 7th November 2012, 05:30 AM   #28
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
Yes the driver board was installed, it is removed now. Should I replace the fets and power up without the driver board installed?

Could some of the DK or AG being leaky or defective cause the 640N's to blow?

The amp idles fine and has a nice square waveform on the power supplt gates. It is producing positive and negative rail voltage of around 80v and all the op-amps have positive and negative supply voltage.

I am thinking I have an issue with the driver board???
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 7th November 2012, 05:43 AM   #29
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Q7, 11, 19 and 22 are generally the problem on this driver board.

I've never seen any of the AG/DK transistors fail on these boards but that doesn't mean that it couldn't happen.

I'd reinstall the outputs with no driver board and confirm that there is no DC voltage on the center legs of the outputs.
  Reply With Quote
Old 7th November 2012, 06:00 AM   #30
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
Will do is imperative I use 640N or will 640 work? I have both just wondering???
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hifonics Brutus BX1605D mike49504 Car Audio 3 25th July 2011 05:12 AM
hifonics brutus BXI1500D elev8rsh0es Class D 1 8th February 2011 04:47 PM
Hifonics Brutus lee1976 Car Audio 3 20th July 2010 11:19 AM
Hifonics BXi2006D Brutus! Formas Class D 0 30th August 2009 05:25 AM
hifonics brutus bxi1206d ray9043 Car Audio 2 30th March 2008 05:36 AM


New To Site? Need Help?

All times are GMT. The time now is 07:40 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2