diyAudio (
-   Car Audio (
-   -   Spl dynamics EXT2000d (

zuarus 3rd October 2012 08:32 PM

Spl dynamics EXT2000d
I need an advice.
I have broken d-class amp. It produces a noise (frequency near 5k). And coils in output filter becomes hot.

I disconnected preamp (all opamps). Noise is not stopped. All mosfets were desoldered and tested. They all are OK.

The amp is old.

Here is the schematic.

zuarus 4th October 2012 08:38 PM

I take an oscilloscope and find distorted squarewave at gates of irf064.
So I find not soldered pin 10 of Tl494. I will solder it tomorrow.

The amp was in service. And TL494 was changed. There are a lot of gumboil. I think serviceman was lowqualified.

Perry Babin 5th October 2012 01:54 AM

If you don't find the fault, post a photo of the audio driver board.

zuarus 5th October 2012 05:59 AM


Originally Posted by Perry Babin (Post 3190394)
If you don't find the fault, post a photo of the audio driver board.

OK.Thanks! I will try to repair it later...

zuarus 6th October 2012 02:56 PM

The sawtooth on tl494 is "modulated". It changes its level.

I have changed tl494, but new one works same. :(

Perry Babin 8th October 2012 02:08 AM

How low is the DC voltage dropping on the following pins:

Pin 11
Pin 12
Pin 14

Place the black probe on pin 7 when measuring.

All times are GMT. The time now is 02:23 PM.

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright 1999-2015 diyAudio

Content Relevant URLs by vBSEO 3.3.2