Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Amp keeps blowing fuses.HELP!!!!!
Amp keeps blowing fuses.HELP!!!!!
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 5th September 2012, 12:26 PM   #1
heydude348 is offline heydude348
diyAudio Member
 
Join Date: Sep 2012
Default Amp keeps blowing fuses.HELP!!!!!

This is an update to a previous post so sorry for that. I have a JL 500/1 (series 1 slash) amp running a single JL 10W7.I have 8 gauge running to the amp from a dist. block that has 4 gauge from the battery. All new runs of wire.Fused at the battery and at the dist. block. Here's the issue.Amp keeps blowing 60 A. fuses. Happens aprox. 10-15 mins. into playing. Checked voltage at amp, 13.25 ish -14.00 ish. Also checed amp draw and is around 12-20 depending on bass notes.Ampa are placed on carpet in rear hatch so plenty of air flow( heat I would think should not be an issue).Any chance a defective voice coil running low impedance would be causing issue? I have not checked voice coil as of yet.I aslo noticed that when the amp/sub are operating properly,even at say 1/2 -3/4 voulume the sub seems to have a lot of "excursion", at least to me, for the music/volume being played.Maybe that is the nature of the 10W7.I also have all the input/settings on the amp at half .
  Reply With Quote
Old 5th September 2012, 05:05 PM   #2
Perry Babin is offline Perry Babin  United States
diyAudio Member
 
Join Date: Nov 2003
Location: Louisiana
Post a link to the previous thread.
  Reply With Quote
Old 7th September 2012, 11:53 AM   #3
AKHeathen is offline AKHeathen  United States
diyAudio Member
 
Join Date: Apr 2011
Location: Anchorage AK
have you read the manual and set the gain with a multi-meter and tone? the amps are notoriously current hungry, not that it should be blowing the fuse. box specs?
  Reply With Quote

Reply


Amp keeps blowing fuses.HELP!!!!!Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
need help - modded amp blowing fuses mfilippello Solid State 14 18th May 2012 05:12 AM
Amp blowing fuses.... Big_Bill Solid State 8 5th October 2009 10:33 PM
Need help: amp blowing fuses Saurav Tubes / Valves 2 1st July 2009 02:17 PM
Car Amp help? Fuses blowing... Tolo Car Audio 1 3rd December 2007 01:42 PM
chinese 845 amp blowing fuses lt cdr data Tubes / Valves 10 24th December 2005 05:51 PM


New To Site? Need Help?

All times are GMT. The time now is 10:41 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki