Question about power supply excess turn-on current - diyAudio
Go Back   Home > Forums > General Interest > Car Audio

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd September 2012, 05:05 PM   #1
diyAudio Member
 
90scaraudio's Avatar
 
Join Date: Aug 2012
Location: ILLINOIS
Question Question about power supply excess turn-on current

Question about power supply excess turn-on current.

When I try to turn-on this amp, as soon as I touch the remote turn-on wire, the current jumps to about 6 amps and then goes into protection.

If I by-pass the protection, it will do the same thing but current will go down to 2 amps idle after the initial 6 amp jump.

Possible bad filter caps?

Is it ok to temp replace them with 1000uf 50v one and try?
It has four 4700uf 50v.

  Reply With Quote
Old 2nd September 2012, 05:10 PM   #2
diyAudio Member
 
seankane's Avatar
 
Join Date: May 2010
Location: Washington State
What type of power supply are you using to try and power this amp up? If it is small or its a computer power supply, the voltage may be dropping enough to put the amp into protect. 6 amp draw upon start up is not that much and if it goes down to 2 amps that seems normal to me.
__________________
Pyramid 52 Amp Power Supply----Fluke 787 Processmeter----Tektronix 465 Scope----Velleman HPS40 Scope----Soldering Iron----Desoldering Iron----Hejet HJ 500-S Heatgun----DM4070 Digital LCR Meter----Propane Torch
  Reply With Quote
Old 2nd September 2012, 08:07 PM   #3
diyAudio Member
 
90scaraudio's Avatar
 
Join Date: Aug 2012
Location: ILLINOIS
K, I think I fixed it. I replaced a 2N6715 and a 10uf 50v cap next to the PWM. Now it starts without going into protect. Oh, its a Zapco.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
jl 500\1 power supply doesnt turn on trevor420420 Car Audio 6 23rd December 2011 11:58 PM
Power tube maximum current draw from a power supply razorrick1293 Tubes / Valves 4 4th November 2011 10:48 PM
Runaway tubes or tubes drawing excess current--baffling trombone Tubes / Valves 13 16th April 2011 11:27 AM
selling high current power supply for power amps. ericpeters Swap Meet 0 14th January 2005 02:21 PM
Removing excess voltage from amplifier supply? Dazzzla Solid State 21 20th April 2004 12:43 PM


New To Site? Need Help?

All times are GMT. The time now is 05:49 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2